WordPress.org

Support

Support » How-To and Troubleshooting » no visual editor when writing !

no visual editor when writing !

  • hello
    when I want to post a new article, I can’t find the visual editor !!! and yes I have “use the visual editor when writing” cheked !

Viewing 15 replies - 1 through 15 (of 57 total)
  • trying to fix the probelme, I just downloaded the “TinyMCE Excerpt” plugin and activated, but still can’t get the visual editor !!

    please ! anyone know what should I do ?

    Moderator kmessinger

    @kmessinger

    Just to clarify. You login, that takes you to xxx/WordPress/wp-admin/post-new.php

    When you get there you click on “Write” tab and nothing happens?

    When I click “Write” I have the page to write a new article, but no text visual editor (the place where you clique icones to put an image, you clique “B” to bold texte )!

    Moderator kmessinger

    @kmessinger

    If you can see the image icon, the B for bold, etc. you are in a visual editor. Is there not an area below the icons to write in? Are you at this url ‘http://www.myurl.com/WordPress/wp-admin/post-new.php’ ?

    BTW, I don’ think had to do this . . . “I have “use the visual editor when writing” cheked !”

    I think either you don’t want to understand, either you are kidding me ! 🙂

    what I sead is totaly clear , I don’t see the visual editor !
    I’m not so dumb to try to write something in :

    ‘http://www.myurl.com/wordpress/wp-admin/themes.php’
    of course Im in :
    ‘http://www.myurl.com/WordPress/wp-admin/post-new.php’

    I don’t have the B for bold, the image icone to inser an image and all the other features.
    take a look at this image

    http://img513.imageshack.us/img513/9950/sanstitre1ql2.jpg

    Moderator kmessinger

    @kmessinger

    Well I did want to understand. Despite what you say, “I can’t find the visual editor !!! ” leaves a lot of room for misunderstanding.:^)

    OK, check this post under WordPress/Support/Miscellaneous
    “WordPress Editor is making me crazy! Don’t apear wysiwyg editor”

    He had a picture of the editor much like yours. In the end he solved it (26 minutes ago) and said, “the site was on a sub dir were .htaccess was OK,but the problem was on the .htaccess on the main dir :(“

    Perhaps this will help you.

    I am having the same problem. When I go to write a new post, there are 2 tabs, visual and code. The buttons that let me add links, bold, images, are all gone, and the code tab does nothing.

    It happens on every browerser on my PC and Firefox on Mac. Only Safari on a Mac will let me edit my post and show all the edit buttons. This is so frustrating as I know everyone else is using IE or Firefox on a PC and I can’t. Anyone be of help?

    Re: kmessinger

    Yes, thank you man, it did help
    unfortunatly I recently uploaded an .htaccess file to the /wp-includes/ directory, and it wasn’t configured well
    thank you again 🙂

    Re: defendthyself

    If you have an htaccess file on your ‘site.com/wp-includes/’
    just delet it !

    I have the same error, could you please help me.
    I saw your conversation and I don’t understand what is htaccess file in wp-includes directory. I cannot find any name htaccess in this directory.

    an htaccess file is in simple words a file that you put in a folder to denie access to it by normal people, if it is not well configured, it can block some settings.

    in my case I had an .htaccess in the folder /wp-includes/ and it blocked the Tinymce (plugin responsible of visual editor) which situated in /wp-includes/js/plugins/tinymce/
    so whene I deleted it, the browser could access the folder normaly and display the rich editor….

    by defaut, there is no .htaccess in the /wp-includes/ directory, there is one in the root of your blog( puted there by your server) so I think you have something that block your brower from accessing the /wp-includes/ directory and getting the tinymce plugin, just undo you last configuration !

    Side note: The file is actually .htaccess (note the dot at the beginning). If using an FTP client to check for files, you may have to instruct it to show hidden files.

    Thank you for your kind support but I still cannot find the .htaccess file in wp-includes folder event I turned on the show hidden files. 🙁

    I think that the Smiley plugin made it happened but i uninstalled that plugin already but the error is still there.

    ???

    I am also having this same problem however there is no .htaccess file. I have confirmed this at the consol level (using “ls -la”) I do have one in the root of my wordpress install that tells everything to use php5 (this webserver has php4 and 5 installed) it also contains some mod rewrite rules. I have no visual editor and the box is checked in my profile to use the visual editor.

    I experenced this after upgrading to 2.3 is there a solution or do I need to think about reverting to 2.2?

    Kaotic, it might be as simple as the visual editor being turned off in your user options… check your own user profile and look for the checkbox at the top for the visual editor.

    Sorry to suggest something so trivial, but I always have to ask if it’s plugged in… 🙂

    Ivovic, we turn on this option in profile already then I ask in this forum!

Viewing 15 replies - 1 through 15 (of 57 total)
  • The topic ‘no visual editor when writing !’ is closed to new replies.
Skip to toolbar