Support » Plugin: Shibboleth » No User Generated, Private browser logon only

  • Resolved lorruche

    (@lorruche)


    I installed this plugin and configured the .htaccess file as well as the plugin settings. There are two problems, though.
    1. Shib logon screen only appears in private browsers.
    2. When a login is successful via shibboleth (in private browser) the user is not generated in WordPress.
    Has anyone ever experienced this or know why this is happening?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jonathan Champ

    (@jrchamp)

    It’s very confusing that you’re only seeing the Shibboleth option in a private browsing session. This sounds almost like overly aggressive caching or some kind of cookie / plugin conflict. There should not be any reason that you cannot see the Shibboleth login option outside of a private browsing window.

    When the Shibboleth login is successful, it will only add the user if you allow new users to be created. If new users are allowed, then it might be that the .htaccess file (which should have the AuthType shibboleth directive) is not be processed. The system-level or virtual host-level configuration that references your Directory must contain AllowOverride AuthConfig at a minimum unless the administrator is willing to move the AuthType directive to the Directory configuration. For full WordPress functionality, you typically also need things like FileInfo, Indexes or even Limit, so trusting administrators sometimes decided to keep it simple and set AllowOverride All. It’s a delicate balance between specific needs and simplicity, but that’s a case-by-case discussion based on your individual dynamic.

    Plugin Author Jonathan Champ

    (@jrchamp)

    Marking resolved for now. If you’re still having issues, please reopen.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No User Generated, Private browser logon only’ is closed to new replies.