Support » Plugin: Toplytics » No “Upload Auth Config File” link to upload JSON file?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Presslabs

    (@presslabs)

    Hello @boulderpoet,

    Thank you for contacting us. Please go try this version that simplifies the auth process a lot: https://github.com/presslabs/toplytics/archive/3.2.zip

    We’ll push this upgrade on wp.org soon, still working on other improvements.

    Best regards,
    ~Presslabs

    Hello,

    Thank you for sharing the new version. I uninstalled the existing 3.2 version. Then when I uploaded the .zip file, it fails with the following message shown in screenshot:
    https://snag.gy/IGws4g.jpg

    Is there another way I should do the install?

    Thanks,
    Dean

    Plugin Author Presslabs

    (@presslabs)

    Hello @boulderpoet,

    That is indeed the wrong archive as it contains the entire dev repository.

    Here is the good one: http://dl.presslabs.net/temp/toplytics-3.2.2.zip containing only the plugin.

    It should allow you to use it without the First part of the setup.

    Best regards,
    ~Presslabs

    Hi,

    Install worked. However, the plugin settings screen shows the same error:
    https://snag.gy/WBAXjN.jpg

    Then when I try to connect to Google Analytics API, it connects, but does not let me choose which API. I paste in the code, then screen refreshes and my analytics account dropdown is empty:
    https://snag.gy/6wWJoC.jpg

    Can I be your beta tester on your new how-to-install instructions? If you are comfortable sharing with me, I can email you directly.

    Thanks,
    Dean

    Plugin Author Presslabs

    (@presslabs)

    Thank you for helping us debug this further.

    Could you provide us with a test account access so we can debug it further?
    You can contact us privately at support@presslabs.com

    Beat regards,
    ~Presslabs

    Hello,

    I fixed this by first logging into WordPress in a browser where I also logged into a Google API account that had only a single Analytics API set up in it. Then your plugin found the correct account, and returned the top posts.

    Thanks for the 3.2.2 plugin, this works great! And it does not add tables to my install — all data pulled from Google Analytics. Super helpful!

    I’ll reach out if there are more issue, but for now we are good.

    Best,
    Dean

    Plugin Author Presslabs

    (@presslabs)

    Hi Dean,

    We’re glad that you managed to sort it out!

    For any other points regarding this plugin feel free to get in touch again.

    Best regards,
    ~Presslabs

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘No “Upload Auth Config File” link to upload JSON file?’ is closed to new replies.