Support » Installing WordPress » No “Upgrade” subpanel under Tools

  • My installation of WP was done through cPanel with my webhost. When 2.7.1 released, I saw the notice on the dashboard to upgrade. However, when I clicked on the link to upgrade, I got an error page stating that I didn’t have sufficient access to upgrade via the link.

    I searched the WP site to see how to fix this so that I could simply follow the link for future releases, and in doing so, I discovered that I’m missing the “Upgrade” subpanel under Tools.

    The page in Codex that I encountered, http://codex.wordpress.org/Tools_Upgrade_SubPanel, shows this “Upgrade” subpanel, but my version is missing it. Under Tools, I only have these subpanels “Tools”, “Import” and “Export”–no “Upgrade”.

    Anybody know why my version is missing this? Is there something that I need to do in order for it to show?

Viewing 15 replies - 1 through 15 (of 15 total)
  • You need to be logged in as an administrator to upgrade. You are most likely logged in as an editor. Your cPanel should tell you the details of the admin account.

    I am logged in as administrator. I’m the only user on the account.

    I will also add that the “Upgrade” subpanel is not appearing on my installation where I’m working on the design/coding for a friend’s blog, nor is the Upgrade subpanel appearing on the installation on her site where the final version will live.

    Both WP installations do happen to be on the same server and were both installed through the cPanel rather than from a download directly from the WP site.

    I don’t know what’s happening. To help me find out what the problem is it would help me if you did the following:

    Try manually going to /wp-admin/update-core.php
    Could you show a screenshot of the page that results.
    Also go to /wp-admin/users.php
    and could you show that screenshot as well.
    Could you tell me which webhost you are using and whether it is possible for you to do a manual upgrade?

    Okay, I am having the same problem. I have two user accounts, one admin and one editor. I log is as the admin all the time, never had a problem before. Trying to go to the update-core.php page results in this:

    http://www.joelp.net/images/upgrade_fail.jpg

    Here’s a screen capture of my user page.
    [removed sensitive info – not a good idea to post that stuff – samboll]

    I’m not sure of my host as I’m hosting via a friend, but I can do a manual upgrade if it’s necessary. I’d rather not have to, though.

    I get the “You do not have sufficient permissions to access this page” for the update-core.php page. And, again, I’m the only user (and administrator) at the moment while I’m developing the blog for a friend.
    update-core page screenshot

    Here’s the users page screenshot, showing me as the only user and set as the admin.
    users page screenshot

    I upgraded to 2.7.1 through cPanel, as I got the ‘don’t have sufficient permissions’ screen when I tried clicking the upgrade link in the notice on the dashboard.

    However, for my friend’s install on her domain, I wasn’t able to upgrade by following the dashboard link and there was an additional error when I tried to upgrade through cPanel. For her site, I had to download 2.7.1 from the WP site and manually FTP files to the server to upgrade from 2.7.

    Both her real site (when it goes live) and my development site for her are on the same dedicated server that I have with BurstNET.

    That shows that you don’t have the full privileges required to do the upgrade. Although the account is called admin it may not have admin privileges. Yes it would be a good idea to scrub out sensitive information first. All I want to see is the role column. Is it set to Administrator next to admin.

    Yes, in the “Role” column it shows the only user as “Administrator”

    I have the identical problem with 2.8 and the 2.8.1b1 as well. I don’t have “sufficient permissions” to access that section.

    cPanel support says it’s a WordPress issue. But has anyone had this problem who doesn’t use cPanel to install WordPress?

    Anyone?

    Peace,
    Gene

    I wanted to update that cPanel support fixed the problem. It required changing a table string in the WordPress database. Once that was done, everything was fine.

    I can get you the string, but I suspect it’ll be better if you have cPanel or your host’s support people work it out.

    I can post the replacement string and instructions if enough people want it, but such things are dangerous (backups advised).

    Peace,
    Gene

    The replacement string and instructions would be great.
    We have a number of folks asking for this.

    And – there are a number of links online – that point to this forum posting as well.

    We understand backups need to be taken
    and – since it is a cPanel issue (at least from the looks of it)
    performing a cpanel backup in a jiffy prior to doing this should be easy enough for folks.

    http://forums.cpanel.net/f21/wordpress-admin-permissions-stripped-installer-126545.html#post550525

    Wonder if they can – or if it can be posted here – but a fix would be great.

    lottasund

    (@lottasund)

    I had the same problem but solved like this.

    Open your wp database in phpmyadmin.
    Under wp-options find wp_user_roles. Replace with:

    a:5:{s:13:"administrator";a:2:{s:4:"name";s:13:"Administrator";s:12:"capabilities";a:64:{s:13:"switch_themes";b:1;s:11:"edit_themes";b:1;s:16:"activate_plugins";b:1;s:12:"edit_plugins";b:1;s:10:"edit_users";b:1;s:10:"edit_files";b:1;s:14:"manage_options";b:1;s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:6:"import";b:1;s:15:"unfiltered_html";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:8:"level_10";b:1;s:7:"level_9";b:1;s:7:"level_8";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;s:12:"delete_users";b:1;s:12:"create_users";b:1;s:17:"unfiltered_upload";b:1;s:14:"edit_dashboard";b:1;s:14:"update_plugins";b:1;s:14:"delete_plugins";b:1;s:15:"install_plugins";b:1;s:13:"update_themes";b:1;s:14:"install_themes";b:1;s:24:"NextGEN Gallery overview";b:1;s:19:"NextGEN Use TinyMCE";b:1;s:21:"NextGEN Upload images";b:1;s:22:"NextGEN Manage gallery";b:1;s:19:"NextGEN Manage tags";b:1;s:29:"NextGEN Manage others gallery";b:1;s:18:"NextGEN Edit album";b:1;s:20:"NextGEN Change style";b:1;s:22:"NextGEN Change options";b:1;s:17:"manage_newsletter";b:1;}}s:6:"editor";a:2:{s:4:"name";s:6:"Editor";s:12:"capabilities";a:34:{s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:15:"unfiltered_html";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;}}s:6:"author";a:2:{s:4:"name";s:6:"Author";s:12:"capabilities";a:10:{s:12:"upload_files";b:1;s:10:"edit_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:4:"read";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;s:22:"delete_published_posts";b:1;}}s:11:"contributor";a:2:{s:4:"name";s:11:"Contributor";s:12:"capabilities";a:5:{s:10:"edit_posts";b:1;s:4:"read";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;}}s:10:"subscriber";a:2:{s:4:"name";s:10:"Subscriber";s:12:"capabilities";a:2:{s:4:"read";b:1;s:7:"level_0";b:1;}}}

    worked for me 🙂

    lottasund tip worked for me!
    Thank you very much!

    TIP: wp_options table is pretty big, if you cannot find wp_user_roles it’s because you only got displayed some 30 records. Have a look at the following myphpadmin wp_options pages or set myphpadmin to display all the records on one page.

    Got a similar problem: my admin account lost most vital capabilities. can anyone tell me which capability is needed to upgrade wordpress so I can manually add it (I know how, just don’t know which capability is responsible for upgrading)

    Btw. is there a way to reset all admin capabilities as I also lost pretty basic ones like: edit pages and its a hassle to manually add them back 🙁

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘No “Upgrade” subpanel under Tools’ is closed to new replies.