Support » Plugin: wpForo Forum » The forum meets my expectations!

  • In any case, the service makes an effort and does not give up even with difficult and complicated users. However, the troubleshooting tips could be more nuanced.

    • This topic was modified 6 months, 1 week ago by andreasbln.
    • This topic was modified 6 months, 1 week ago by andreasbln.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author gVectors Team

    (@gvectors-team)

    Hi @andreasbln,
    Thank you for the review. Your problem comes from your limited hosting service. For some reason it doesn’t support the most popular MySQL database table engine InnoDB, this is why the new table was not created on update and your site was down.
    That’s a pity that wpForo got a bad review because of your server limitation.

    I recommend you to contact to your hosting and let them know thier MySQL doesn’t recognize InnoDB engine, this is too bad.

    Thread Starter andreasbln

    (@andreasbln)

    MySQL / MariaDB / Percona Version 10.1.47 (2020-10-07)

    My hosting service says I should install software that is compatible with modern MySQL servers and not rely on incompatible products.

    As a customer, I’m always the stupid one!

    Plugin Author gVectors Team

    (@gvectors-team)

    Thank you for the update, you just need to forward my message to them. And ask a question why the it doesn’t recognize InnoDB table engine. This is the issue.

    Plugin Author gVectors Team

    (@gvectors-team)

    MySQL / MariaDB / Percona Version 10.1.47 (2020-10-07)
    My hosting service says I should install software that is compatible with modern MySQL servers

    BTW, current stable MariaDB version is 10.5.8, so your server MariaDB is very outdated. Ask them to update to 10.3.0 or higher. This should fix the limitation.

    The InnoDB limitations could also be a result of MariaDB wrong configuration. They should make sure the InnoDB is enabled.

    Thread Starter andreasbln

    (@andreasbln)

    Ubuntu 18.04 is shipped with MariaDB 10.1. MariaDB 10.x version is a drop-in replacement for MySQL 5.5-5.7. and the standard for all Plesk installations for WordPress.

    OK, many users and future customers will only be able to switch to other forum software!!!

    Plugin Author gVectors Team

    (@gvectors-team)

    I tried to make your server better and up to date. Just don’t worry we’ll do our bes to make wpForo compatible with servers like yours as well. The update comes today.

    Plugin Author gVectors Team

    (@gvectors-team)

    And as I mentioned many times this is a limitation issue not the old/new version issue. The InnoDB engine is limited on your hosting service, it seems they disabled the InnoDB support. That’s why I asked you to let them check it and enable.

    Thread Starter andreasbln

    (@andreasbln)

    Plesk say:

    The mode switches off InnoDB engine in MySQL database server, and Apache web server modules that are not critical for hosting services. This makes Plesk use less memory than other control panels available on the market, which ensures better utilization of hardware resources and increased density of virtual environments per server.

    There are 20 WordPress installations on my Plesk server and now should I give up this speed advantage for a single plugin?

    Should there be another way?

    Plugin Author gVectors Team

    (@gvectors-team)

    As I said the wpForo update comes today especially for your case.

    The mode switches off InnoDB engine in MySQL database server, and Apache web server modules that are not critical for hosting services. This makes Plesk use less memory than other control panels available on the market, which ensures better utilization of hardware resources and increased density of virtual environments per server.

    This is not good, InnoDB has become one of the most popular choices thanks to its high levels of performance and reliability compared to other storage engines. Please read this article: https://www.ionos.com/digitalguide/hosting/technical-matters/what-is-innodb/

    It seems they have very poor servers or your hosting plan is limited. Believe me, that’s not good that your hosting InnoDB is disabled.

    Plugin Author gVectors Team

    (@gvectors-team)

    Hi @andreasbln,
    The new version is released. It’s adapted for your case. Please update and let me know if you succeed.

    Thread Starter andreasbln

    (@andreasbln)

    Version 1.9.1 shows no changes. After activation, the web server produces a 503 error and can no longer be used.
    What have I done:

    Disable all wpForo an all wpForo plugins
    Clear cache and opcache
    Delete wpforo directory
    Install and activate version 1.9.1
    WordPress stopped working with a 503 error.

    On the fly, this is frustrating for the forum users. I have to create a clone of WordPress first to test this further.

    The innoDB tables don’t seem to be the problem and at first glance I don’t find any PHP errors either. I’ve tried it for several hours and will stay with version 1.8.4, it works very well and I and my users are very satisfied.

    Never change a running system!

    It is only annoying when you have switched on an automatic plugin update, which stops the WordPress server from running completely after an update from wpForo.

    In the long run this is not a good solution if stability is required and I will look for another forum software. Assign a PHP programmer to program a data transfer for me.

    I will publish the plugin so that other affected wpForo users also have the opportunity to switch to working alternatives.

    It is not a good basis for running a forum if, after 2 years, you suddenly have to fear that the entire operation of the forum will have to be stopped when updates are made.

    Plugin Author gVectors Team

    (@gvectors-team)

    @andreasbln,
    This is very strange. You are the only user who still have this problem. wpForo were updated on dozens of thousands site during the last 1-2 days without any issue.

    So, please contact us via support[at]gvectors.com email address, we’re going to help you fix the issue individually. We want to see why your server is so different and what other limitation you have. Please contact us asap, and we’ll help you quickly.

    Thread Starter andreasbln

    (@andreasbln)

    I found and solved the problem myself. The solution was simple, how does my installation differ from the others?

    I made the following change, which worked up to version 1.8.4:

    https://wpforo.com/community/postid/16663/

    With version 1.9.1 this change brings a memory error that is displayed as a 503 error and brings WordPress to a halt.

    After I’ve removed the change, everything works as the developers intended.

    Thanks for the support!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘The forum meets my expectations!’ is closed to new replies.