[resolved] No update required after update to 3.3 (11 posts)

  1. bonusreviewer
    Posted 4 years ago #

    After i updated from 3.2.1 to 3.3 i am getting a screen saying
    "No update required" - Your WordPress database is already up-to-date! when trying to go to the Dashboard.

    I only can click the Continue Button, which redirects my to the home page of my site.

    Can somebody tell me what i can do to fix this problem ?

    I cannot reach the WordPress Dashboard.

    Thank you in advance

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    - switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - re-running the upgrade via wp-admin/upgrade.php

  3. bcorcoran
    Posted 4 years ago #


    This happened to me just now. The script hung because the database upgrade took a while and didn't complete it's post database upgrade functions.

    Go into your database (using PHPMyAdmin or other database tool) and go to your wp_options table (or $prefix_options) and find the row with option_name of "db_version". The option_value of this row should be 19740 (wp 3.3). Change this value to the corresponding value in the following list:

    3.3.1 = 19470
    3.2.1 = 18226
    3.2 = 18226
    3.1.4 = 17516
    3.1.3 = 17516
    3.1.2 = 17516
    3.1.1 = 17516
    3.1 = 17056
    3.0.5 = 15477
    3.0.4 = 15477
    3.0.3 = 15477
    3.0.2 = 15477
    3.0.1 = 15477
    3.0 = 15260

    More available here: http://codex.wordpress.org/FAQ_Installation under the "Force Database Upgrade" section.

    Then run /wp-admin/upgrade.php and it should ask you to upgrade.

    This worked for me, hopefully this helps you too.

  4. bonusreviewer
    Posted 4 years ago #

    I just cleared my history - the cookies etc. and the problem was gone.

    Thank you anyway.

  5. Chris Burbridge
    Posted 4 years ago #

    I did try changing the db_version value. Then it told me I needed to upgrade ... but once I did that, it sent me _right_ back the same old "No upgrade needed" / home page loop. So I don't think that did anything.

    What I finally did was move my themes directory, my plugin directory, *AND* several files that W3 Total Cache puts at the root of wp-content/:


    At least, it looks to me like these are all part of W3 Total Cache.

    Anyway, when I did that, I was able to load the back-end. Then, I was able to re-introduce themes/ and plugins/, and then the W3TC files.

    I'll bet you anything that what was the culprit was the W3TC files, because that is what is most anomalous to my install, from a generic install.

  6. TCWriter
    Posted 4 years ago #

    I updated and suffered the same repeating "No Update Required" screen.

    I simply deleted the W3 Total Cache files and everything started working.

    That might be the source of the error for many....

  7. Chris Burbridge
    Posted 4 years ago #

    I don't think you actually have to delete the files, just move them out of wp-content; then, load the back-end; then, put them back in. That was my experience.

  8. Flagging this resolved.

    That looks like the OP had a browser cache problem, and the other two folks have app cache (which ... W3TC shouldn't be caching the BACK end of your site). Try just flushing the w3tc cache next time.

    I wonder if I should suggest that to the dev.

  9. bcorcoran
    Posted 4 years ago #

    Ipstenu, the problem is you can't flush the W3TC cache because you can't get into the admin panel at all.

    You literally have to stop W3TC from running to get your admin panel back. (or manually upgrade db like i did)

  10. barry-coffeesprout
    Posted 4 years ago #

    You can try flushing your cookies and going to /wp-login.php
    Worked for me

  11. nostratosphere
    Posted 3 years ago #

    I solved this issue for my girlfriend quite easy to be able to login to the dashboard again.
    when you get the website with the "No update required" message, don't click on continue but instead goto the adres bar.
    it should say something like:

    Simply remove the text in the url behind wp-admin and press enter.
    So remove: /upgrade.php?_wp_http_referer=%2Fwp-admin%2F

    (This removes redirecting to the upgrade)
    You should get the dashboard login.

    It worked for our problem.

Topic Closed

This topic has been closed to new replies.

About this Topic