Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » No update date given on statement – followup

  • Resolved Timeout

    (@farcasterwien)


    Hello Leon,

    the date issue can be seen here.

    Do you have no other issues with date notations on your site?

    no, not really.

    greetings
    Helmut

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @farcasterwien,

    We don’t have a direct answer, I can’t see any issues on your site. I would suggest clearing your cache, if you have a CDN, please update there as well.

    Below on the cookie policy is the sync with Cookiedatabase.org date, which is shown correctly.

    Could try clearing cache and see if it works?

    regards Aert

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    @farcasterwien, The date is saved when you change a setting in the wizard. The wizard then saves a unix timestamp. When the document is loaded, the timestamp is converted to your date format based on the date format you have saved in the general WordPress settings.

    Did you try changing one setting, then save it? After saving, you can then change the setting back. This will force the plugin to update the timestamp. This should then reflect in your cookie policy.

    Thread Starter Timeout

    (@farcasterwien)

    The date is saved when you change a setting in the wizard.

    Maybe, but its sadly not displaying. I changed several things, saved them, cleared the cache and the changed things were visible on the statement-page, but the date in the first line (was last updated…) remains on January 1st, 1970.

    As stated, this happens here in the german version.

    Well i now just hide the paragraph…

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    What happens if you add

    update_option( 'cmplz_publish_date', time() );

    To your theme’s functions.php? This will force the date to the current unix timestamp.

    After loading the site, you can remove the line again. If the date still doesn’t show up, it’s not in the date registration, but in the output, and we can check from there.

    Thread Starter Timeout

    (@farcasterwien)

    @rogierlankhorst
    this worked. date is now displaying correctly.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @farcasterwien, great it worked! I’ll close this for now, if you run into any issues in the future, let us know!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘No update date given on statement – followup’ is closed to new replies.