Support » Plugin: Twitter Widget Pro » "No Tweets Available"… mostly

  • Either the new update broke my plugin or the timing of this error is coincidental— I get “No Tweets Available” 9 times out of 10 on my site at the very bottom

    Site has rather low traffic, and it seemed okay once I got the plugin updated but while working on CSS it just suddenly stopped working *most* of the time. Occasionally I will reload the page and see a few tweets. My code:

    <?php echo do_shortcode(' [twitter-widget username="YamamotoIND" hidereplies=false hidefrom=false avatar=small items=7 title=TWITTER showfollow=false showretweets=true showintents=false fetchTimeOut=60 showts=30]'); ?>

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author Aaron D. Campbell


    You successfully created the Twitter application and authorized the YamamotoIND user?

    Sure did. Seemed to be working fine for a few minutes.

    I’m seeing the same or similar behaviour on my test site (out of the box WordPress + your plugin, nothing else). Worked for a bit after updating to 2.5.2, then showed ‘No tweets available’. I’m occasionally seeing the tweets, but only after changing some settings (and not every time).

    WordPress 3.5.1
    Twitter Widget Pro 2.5.2

    Hi there,

    I’ve also suddenly just got this. Just logged on to my site after a few days and noticed the Twitter widget says “No Tweets Available”. Also the CSS is a little out of whack – I’ve made no changes to it.

    I have not yet updated to the latest version of the widget – still using Version 2.4.1 with Worpdress 3.5.1.

    Any ideas?

    Thank you.

    Okay…never mind…issue resolved.

    For some reason…my settings’ page for the widget had been set to default. Don’t ask me how…I’ve not been working on the site for a few days…and it was working fine then.

    In any case…all working fine now.

    Sorry…jumped the gun on this…I accidentally switched to my localhost version of the site where it was still working. The live site still has the same problem.

    I’m in the process of upgrading the widget – we’ll see if that helps.

    Switched on WP_DEBUG:
    Notice: Trying to get property of non-object in on line 869
    The same for lines 1149, 1150, 1153 and 1155

    Behaviour is consistent:

    • I get “No Tweets Available” (and the above notices), but the follow button with the correct username is showing
    • when I change a setting, I see my tweets (and no warnings or notices) on the first reload. I reload the page again, and they’re gone
    • changing settings doesn’t always have that effect: it seems I need to wait a while to recreate this behaviour

    Clearing update locks: “There were no locks to clear!”
    Rate usage looks okay, nowhere near the limit

    Updating to 2.5.3 got rid of the PHP notices mentioned above, but the issue is still the same: “No Tweets Available”

    For the record, I upgraded to Version 2.5.2 (WordPress: V.3.5.1) and it’s all working now.

    I went through all kinds of settings, and now I see the following:

    • If I set the number of items to 1, 2, 3 or 4, the tweets show consistently, no errors – at least at the moment.
    • If I set the number of items to 5 or higher, I either get ‘No Tweets Available’, or they show on the first reload and disappear again thereafter.
    • Tweeting (adding a new tweet to my timeline) increases the number of “working” items: up to 5 items show, setting it to 6 results in ‘No Tweets Available’. And so on.

    This pattern suggests that something in the process seems to choke on older tweets (about 6 or 7 days old), and the widget fails to display even the newer ones.

    I hope that helps – might also explain why so few people seem to experience this issue.

    I’ve used this plugin on a couple different client sites in the past month or two, and I didn’t have any issues until I upgraded to 2.5.0. A previous client website that hasn’t been upgraded from 2.4.1 is displaying their Twitter feed as expected, but on my most recent installation of the plugin I am getting this ‘No Tweets Available’ in defined sidebar where the widget is placed.

    On the most recent site, I began development with 2.4.1 and upon upgrading to 2.5.0 I started seeing this message more and more frequently after the first day. I went through the necessary steps to approve and assign the app within the client’s Twitter admin, and it will display their Tweets very, very occasionally (1 out of every 20+ page loads).

    Here’s a link to the dev site, though there’s nothing to really see because the plugin isn’t outputting anything other than the message.

    Edit: The site is using the latest WordPress release.


    I had a quick look – your client’s last tweet is from 6 March. On my test site, the widget also seems to choke on tweets from 6 March or older (as of today). It suggests a certain pattern.

    (edit: I see you’re testing, and the newer tweets are showing on the site. I wonder if you can recreate the behaviour that I am seeing: do all the tweets disappear if you set the number of items to include an older tweet?)

    It’s difficult to test, because if my guess is right and tweets that are “too old” take down the whole output, then people who tweet 3 times a day or more will never run into this behaviour, even if they display the full 20 items.

    Aaron – I’d be happy to give you access to my test site if that helps at all.


    I saw your earlier post about the issue you were having with Tweets in the feed from about a week or so ago breaking the plugin, so I thought I would test that theory out and put 2 brand new Tweets out.

    Like you just saw it fixed the issue, but obviously I can’t guarantee someone else’s Twitter activity. The client on the other dev site that hasn’t experienced the same issue Tweets between 5 and 10 times per day, so this suggests your observation is probably correct.

    Unfortunately, I really like this plugin but it looks like I’m going to need to use a different one for now until this issue [hopefully on the next update] gets resolved.

    Update: I deleted one of the Tweets and after the plugin’s cache was reset, the output went back to ‘No Tweets Available’

    I agree: you can’t tell people to keep tweeting or else their site will go weird 😉

    And I second the thoughts about the plugin in general: it’s fantastic when it works – exactly what I’ve been looking for.

    As for the issue itself, I’m happy to see someone else can reproduce what I’m seeing – perhaps Aaron can shed some light, or use this information to investigate.


    The widget – or the API – seems to choke on Emoji characters. I deleted a tweet containing Emoji, and the widget works as expected. When I add it again, I see “No tweets available”. Will keep an eye on it.

    Aaron, any comments on that?

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘"No Tweets Available"… mostly’ is closed to new replies.