Support » Plugin: WooCommerce Blocks » No translation on front-end

Viewing 15 replies - 1 through 15 (of 15 total)
  • Thread Starter dalias

    (@dalias)

    Here is valid image of Front end

    • This reply was modified 1 year, 1 month ago by dalias.
    Plugin Support Cara – a11n

    (@dcka)

    Hi, @dalias!

    To confirm, you’re using the Checkout block, is that right?

    If yes, we are tracking some translation-related issues on the All Products block, and this might be related.

    There is already a fix that is awaiting review that may be included in the next version of WooCommerce Blocks. That said, there is no timeline yet for when that will be released. If you have a GitHub account, you can follow that pull request to receive updates.

    Thread Starter dalias

    (@dalias)

    Hi @dcka!

    Its cart block.

    Plugin Support Cara – a11n

    (@dcka)

    Thanks for confirming, @dalias!

    I’ll run additional tests on this and, if I’m able to reproduce the issue consistently, I’ll confirm with the developers if this is related to the issue that’s already being fixed here: Handle translations in lazy loaded files.

    I’ll keep you updated either way!

    Plugin Support Cara – a11n

    (@dcka)

    Just wanted to give you an update here, @dalias!

    I ran some tests and I was able to reproduce the issue you’re seeing. I’ve passed my findings along to the developers, and they say that it looks like this issue is not related to the one being fixed here: https://wordpress.org/plugins/wp-staging/, so we’ll need to investigate further.

    As before, however, I’ll keep you informed of what we find!

    Thread Starter dalias

    (@dalias)

    Tanks for keeping me updated @dcka!

    Please note, that this issue does not occur on admin panel in page edit mode – translation is fine here. The bug is only on frontend.

    Plugin Support Cara – a11n

    (@dcka)

    Please note, that this issue does not occur on admin panel in page edit mode – translation is fine here. The bug is only on frontend.

    Yes, that is noted. For context, I ran tests with English, Spanish, and Polish to compare “Shipping Method” in the front end and the back end. It looks like the back end is using “Shipping” but front end is using “Shipping method.”

    As a possible workaround, you may want to try a translation plugin like Loco Translate to translate instances of “Shipping method.” If you’re interested, we have steps on how you can do that here: Creating custom translations with Loco Translate.

    Thread Starter dalias

    (@dalias)

    Thanks @dcka for hotfix with LocoTranslate! 🙂

    I can’t really mark this issue as resolved, but this will do fine until plugin will be fixed.

    • This reply was modified 1 year, 1 month ago by dalias.
    Thread Starter dalias

    (@dalias)

    Hi @dcka!

    Unfortunetaly I found another transalte bug in Polish.

    When you set product on sale in cart there is label “SAVE” (pic)

    And it’s translated to Polish as “zapisz” (pic). Techlically it means “save” but its about saving a file rather then money.

    This translation is wrong and I can’t find it in Loco Translate to change.

    Proper translation for this should be something like “Oszczędzasz”.

    Plugin Support Cara – a11n

    (@dcka)

    Thanks for pointing that out, @dalias!

    It’s not necessarily a bug, but an error in the submitted translation, which I can see here.

    For that, I would invite you to contribute the correct translation, which you can already start doing since you already have a WordPress.org account. If you’re interested in helping out with Polish translations, you may want to look into this: Getting Started.

    Thread Starter dalias

    (@dalias)

    Thanks for that @dcka! I have submitted my proposal of translation 🙂

    Plugin Support Cara – a11n

    (@dcka)

    You’re welcome, @dalias!

    I know this isn’t technically resolved for you yet, but since a fix for the cart block issue is already being worked on by the developers, I’ll go ahead and mark this thread as resolved.

    You can track the progress of the fix here too: Handle translations in lazy loaded files. Or, you can check the WooCommerce Blocks changelog when it’s updated.

    If you have related questions though, feel free to ask them here again or even open a new thread. We’ll still be here! 😄

    Thread Starter dalias

    (@dalias)

    Hi @dcka!

    Is there any progress in updating translations? I submitted Polish translations more then month ago, and they still have “waiting” status.

    Plugin Support melinda a11n

    (@melindahelt)

    Automattic Happiness Engineer

    I would recommend requesting a PTE status by following the steps at https://make.wordpress.org/polyglots/handbook/plugin-theme-authors-guide/pte-request/#for-translators

    That will help find out when the “waiting” status will be incorporated.

    Thread Starter dalias

    (@dalias)

    It’s been a while, but I submitted request. Thanks! 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘No translation on front-end’ is closed to new replies.