• Just discovered that I have no tracking data at all coming from one of our websites. The problem coincides with the update of the plugin from 4.9.6.2 to 5.0.0.1 on May 30th. View Source shows no code inserted on the page.

    We have other sites using this same plugin, on the same server, that work fine.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter TechDaddyK

    (@techdaddyk)

    Tried uninstalling and installing again. Same problem.

    Thread Starter TechDaddyK

    (@techdaddyk)

    Noticed that my sites that DO work have additional tabs on the Google Analytics Tracking Code page: Events Tracking, Custom Definition, Exclude Tracking, Advanced Settings, and Integration.

    The site that DOES NOT work has only Basic Settings. And on that page, there are only the two drop-downs; View Name, Tracking IDs, Default URL, and Time Zone do not show at all on this page on this site.

    I’m having the same issue. It was working fine until the latest update.

    Although UA numbers are the same in WordPress and Google Analytics, the GA dashboard says there is a Tracking Code Mismatch, and the WP dashboard says it hasn’t collected enough data.

    I have the same issue with two websites.

    • This reply was modified 4 years, 4 months ago by paraisa.

    Hi,

    @techdaddyk in your Tracking Code screen make sure Analytics is selected as the tracking type. Also look in the Errors & Debug screen if there are any errors listed. If those look okay, please post the plugin’s settings from the same screen.

    @paraisa Can you also tell from which version have you upgraded?

    • This reply was modified 4 years, 4 months ago by Alin Marcu.

    @deconf We have automatic updates turned on. So had not noticed version number prior to 5.0.1.

    Can you make the same checks mentioned above?

    Please note that even if the automatic upgrade is enabled the plugin only updates automatically from versions like X.Y.Z.o to X.Y.Z.u, it won’t upgrade automatically on major releases, unless you’re using a management system that does so.

    @deconf Thanks for the prompt reply.

    FYI: Managed to get one of the websites working again by clearing authorisation, and re-authorising.

    However, the other website still displays: “Not enough data collected (-21)”

    • Checked error screen – no errors.
    • Checked Tracking Code Screen – Analytics are selected.
    • Websites are checked for updates on daily basis, so we had whatever was the most recent version prior to 5.0.1
    • Cleared the website cache through our hosting company’s C-Panel tools.
    • Cleared authorisation and re-authorised GADWP plugin
    • Double-checked page source, theme options, GADWP plugin settings and our Google Analytics settings and all display the correct UA number.

    • This reply was modified 4 years, 4 months ago by paraisa.
    • This reply was modified 4 years, 4 months ago by paraisa.

    Error -21 it’s fine, it indicates that there was no data collected on the selected time frame.

    It has displayed the same error for days and Google Analytics says there is a tracking code mismatch, even though there isn’t.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘No tracking since update to 5.x’ is closed to new replies.