Support » Plugin: Elementor Page Builder » no title= tag using image widget

  • Resolved bphillip2

    (@bphillip2)


    I have been building a new version of my site with Elementor for 3 weeks now, so far so good. I cannot however seem to get the image widget to put in the “tool tip”, or image title text into the html. Alt text yes, but when I inspect, the title attribute is not there. You can add it manually when you “edit” a photo that has been inserted in a text widget. Am I missing something? Would this not be needed for SEO?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Support Ben Pines

    (@benpines)

    Hi Phillip,
    You can add the title and alt from the image media library of WordPress.

    Hi Ben!

    Have the same issue, img title tag is missing in the html code (only alt title is displayed). I have added a title tag in the media library for every image but it does not work.

    Moreover, once you edit a page with WP Editor instead of Elementor, img title is still missing in text editor. Have added manually there as well, but once switched over to Elementor editor, img title is missing again.

    Would love to get this solved soon!

    Best

    Same here! I have added a title tag in the media library for every image but it does not work.

    For example on this page:

    http://brudiletten.de/adiletten-damen-herren-badelatschen/

    It seems to have happend with one of the latest Updates

    • This reply was modified 1 year, 8 months ago by  brudi.

    Ben, I have the alt tag, title and description all filled out in the media library. It still does not work using the elementor image widget. As I said in my post they work when inserted into a text box widget, so you know I have my media fields filled out.

    Is it you job to just mark these as resolved, or actually resolve issues? If it helps I paid for elementor.

    this really shoud not be marked as resolved. I also use the paid elementor pro version and it worked fine at the beginning.

    Please fix this. I get lots of traffic through some images – if the title tag is missing thats really bad.

    I am also paid for the Pro version and am experiencing the same problem. I’m currently on a project that requires an entire site to be migrated into WordPress; manually going into the code just to add the title text is going to make the process so much longer.

    I tried using the Restore Image Title plugin but that only works if you’re using WordPress’ built-in editor.

    @benpines: at least please reopen the thread, because this problem obviously does not seem to be solved.

    • This reply was modified 1 year, 8 months ago by  brudi.

    Same problem here: http://mausarrest.de/

    Please fix that and reopen the tread.

    I had submitted a ticket before I found this thread and this is the response that I received:

    I am afraid the currently Elementor’s Image widget doesn’t have such way to include the title in meta.
    I will submit your feature request to our development team and hope they will come up with a solution in one of the future release.

    Does someone want to start a new thread with the same problem as I doubt they’re checking on this since marking it as resolved.

    Im not 100 % sure but i thougt , that it worked some weeks ago but changed with one of the last updates.

    @spandipants go for it and start a new thread – i think its a good idea

    I’ve created a new thread here: https://wordpress.org/support/topic/cannot-add-title-text-to-images/
    Feel free to jump in and comment before they mark it as resolved 🙂

    I’ve also been playing around with possible solutions until Elementor can fix this. I installed the Restore Image Title plugin and if I add images using Elementor within a text editor widget then the title text works. It takes the title of the image from the Media Library and uses that for the title text. I haven’t tested this extensively but it could be a possible interim solution.

    To mark this as resolved is a joke. Still no title tag in the image widget. For SEO it is really important.

    Hi, I’ve the same problem! I need to add the title tag für seo purposes. It would be very nice if you could show us a solution 😉 The Plugin “Restore Image Title” unfortunally didn’t work in my current projekt…

    it works

    add this line to includes/controls/groups/image-size.php at line 98

    'title' => trim(Control_Media::get_image_title( $image )),

    like below

    
    $image_attr = [
        'class' => trim( $image_class ),
        'title' => trim(Control_Media::get_image_title( $image )), //*** add this line
    ];
    

    Great! It works. But it is not update-secure, isn’t it?

    Hello Elementor,

    please add these lines above from erenkorkmaz to elementor!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘no title= tag using image widget’ is closed to new replies.