Support » Fixing WordPress » No Thumb on Facebook

  • NicotineLL



    I’ve this annoying problem – no thumbs are generated when I try to post a link to my blog. This occurred a couple of days ago. I read some topics about the subject but couldn’t find solution. The funny part is that even if I try to post an image with it’s full URL it’s still the same – no thumb. There are few rare exceptions that generate thumbs (for example if I try to share my index, a few thumbs are generated and the posts containing this images can also be shared and to generate thumbs).

    My blog:

    Here are a few reasons that I think might cause the problem:

    – I’ve added a function which generate thumb for “Pin It” button (view code – ).
    – I use cache plugin.
    – I failed to install CloudFlare (which sometimes shows warnings even though I delated the site from their DB and both my DNS are changed to original – as provided for my hosting).
    – I use CPanel’s “Optimize Website” with “Compress all content” (all MIMEs)
    – Facebook is blocking images from my site
    – Facebook is blocking images with filenames like mine (351fe55eca29d36c3fc379391623eaaf.jpg)

    Have you had this problem? Do you know a solution?

Viewing 5 replies - 1 through 5 (of 5 total)
  • damoncloudflare


    The DNS is still pointing to CloudFlare (see below) & your DNS change back to the registrar hasn’t completed yet. 296 IN A 296 IN A

    “The funny part is that even if I try to post an image with it’s full URL it’s still the same – no thumb.”
    What I think might be happening:
    Are you getting a 503 response error with Facebook’s debugger tool? If so, we do have an open bug with Facebook about this.



    I don’t know why you get those DNS servers, but when I check them I get these [‘’] [‘’]

    Anyway, when I put full image URL in the debugger tool I do get a 503 error. What does that mean?



    The change didn’t happen when I checked (looks ok now).

    Are you still getting the 503 issue even with CloudFlare off?



    No, but now I get “Response Code 206” – Can’t download: Could not retrieve data from URL.

    Just a quick note that we have fixed the debugger issue with Facebook returning intermittent 503 response codes (if you come back to CloudFlare). If you’re still having issues with the debugger not on CloudFlare, we’re not the cause of the issues you’re having right now.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No Thumb on Facebook’ is closed to new replies.