Support » Plugin: Smush Image Compression and Optimization » No Text Box When Uploading Image

  • Resolved Tnace

    (@radiocure1)


    When I upload an image the text box is missing to enter in the description/caption. If I save then go back to the image it appears but it’s pretty annoying. Any ideas why the text box is missing?

    Here’s a screenshot of the issue: http://tinypic.com/r/119uhye/9

Viewing 12 replies - 1 through 12 (of 12 total)
  • Tnace

    (@radiocure1)

    Any help here?

    Plugin Author Umesh Kumar

    (@umeshsingla)

    Hey @radiocure1,

    Do you see any JS errors in web console? What WP version you’re on?

    The featured image popup seems to be different in styling, is it a custom post?

    Thanks, Umesh

    Tnace

    (@radiocure1)

    No JS errors that I can see. Running WP 4.9.4. It’s not a custom post but a built in feature of the SimpleMag theme. None of the previous versions of WP Smush caused this. Any other ideas?

    Plugin Author Umesh Kumar

    (@umeshsingla)

    I’ll check with SimpleMag theme and try to replicate it, else we can look into other possibilities.

    Tnace

    (@radiocure1)

    Thanks Umesh, let me know when you’re able to test the SimpleMag theme.

    Plugin Author Umesh Kumar

    (@umeshsingla)

    Hey @radiocure1,

    Apologies for the delay in response, where can I replicate this with Simplemag in my setup? I mean what section I need to go to.

    Thanks, Umesh

    Tnace

    (@radiocure1)

    It’s just the normal post draft and featured image, but I think it happens whenever an image is uploaded to a post.

    Plugin Author Umesh Kumar

    (@umeshsingla)

    @radiocure1, Just to update you I was able to replicate it, and looking to fix it.

    Tnace

    (@radiocure1)

    That’s good to hear, let me know when you’ve come up with a fix!

    Tnace

    (@radiocure1)

    Any update on this? It’s been over a week and I’ve had to disable the plugin as it’s not working.

    Plugin Author Umesh Kumar

    (@umeshsingla)

    @radiocure1, For now you’d need to add this code to one of the plugins, or your theme functions.php. This would fix the issue of text box not appearing.

    Also, it’d remove the Smush Now! button or Smush stats displayed on attachment details screen which shouldn’t be much of a issue. If you’re using “Automatically Smush my images on upload” option, images would be optimised by default.

    function smush_dequeue_script() {
       wp_dequeue_script( 'smush-media-view' );
    }
    add_action( 'wp_print_scripts', 'smush_dequeue_script', 100 );

    Make sure you remember where you’ve added code, as a proper fix would be included in next smush release, post that you’d need to remove this code.

    Let me know, if I could be of any further help.

    Thanks, Umesh

    Tnace

    (@radiocure1)

    That works perfectly, I’ll keep in mind to remove that code when WP Smush updates again. Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘No Text Box When Uploading Image’ is closed to new replies.