Support » Plugin: Glossary » No terms appearing: term count not updating

  • Resolved Arthur

    (@aahkendall)


    I’ve just installed the plugin and have added a couple of terms in two categories, as well as adding a couple of sub-categories.

    So far nothing is appearing except the categories and on the settings page the terms count is showing as 0 even though the glossary page itself is showing the two entries.

    I am getting a message saying thanks for installing and to check my email for an activation link, but have received nothing…would this be preventing it from working? I can’t imagine so, but…

    Thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi Arthur,
    did you enabled the post types for glossary in the settings panel?

    The counter is updated with a cron daily.

    Thread Starter Arthur

    (@aahkendall)

    Hi Daniele,
    It was on a page, for which it was enabled. I have enabled for posts too, but it’s still not working (obviously, as I have no posts yet!) and the post count is still not updating. I’m aware it’s a cron job and have tried updating manually too. Neither time nor manual updating is working…

    Do you have the pro version of the plugin?
    How many terms do you have?
    Can I have the website link?

    Thread Starter Arthur

    (@aahkendall)

    Thanks for your reply.

    1. I am testing the plugin, so I haven’t got the pro version yet.

    2. So far I have only created a couple of test terms, in two different categories, one of which is a subcategory.

    3. The site is under development, so the page is set to private (clearly I cannot publish it until a) I have a minimum number of terms and b) the glossary is actually working as I want, not just all terms in all categories mixed together, which is how the default glossary page appears to work in the free version (hence me creating a new page using shortcodes to sort by category).

    I am trying to understand the status of the data in the plugin.
    Do you have any visual builder or a page builder?

    Usually with those plugins Glossary doesn’t work as they don’t act in a standard way and don’t execute the_content filter.

    Thread Starter Arthur

    (@aahkendall)

    Ok, I have now created a staging site and set the page status to Published.

    Now I am getting a list of terms for the shortcode [glossary-terms] but the parameters are not working – I have tried with both the category slug and ID [glossary-terms tax=”25″] as per your documentation. But in all cases the shortcode lists all the terms from all categories…

    By the way, for the new page I am using Gutenberg. I do have Elementor installed, but wanted to keep it simple for this one to avoid problems…

    You can see the page here: https://staging3.gapsfamily.org/glosario/ (it’s in Spanish and I’ve not translated anything yet, but you’ll see what I mean. I am assuming I can translate the “Glossary Term” string at the top of the main Term page/custom post. I’m using WPML.

    Thanks for the quick replies. We’re making progress!

    I don’t understand the issue of Glossary Terms. I see two sections with 4 terms each.

    I think for your needs is more useful the Glossary List shortcode available in the pro version: https://docs.codeat.co/glossary/shortcodes/#glossary-index-premium
    You can see in action here: https://demo.codeat.co/glossary/

    About the localization I don’t understand that part of that page is not localized as I see Glosario.

    Thread Starter Arthur

    (@aahkendall)

    Can you not see that the second section is actually two terms repeated?

    As I said, the two terms are in separate categories. With the “tax” parameter I should be able to display only the terms in a specific category, but it is displaying all the terms. The category shortcode (listing the categories and sub-categories, appears to be working.

    I have updated the page (“Glosario” = “glossary” in English…) to better reflect what I am trying to do. The first category, Microbiota (that’s the same in English) should have just one term, “Metagenoma”, the second (sub)category – “Macronutrientes” (Macronutrients) should have also one term, “Carbohídratos” (Carbohydrates) and the third one, “Micronutrientes” (Micronutrients) should be blank as it has no categories.

    This is a non-profit, so until we have completed the main structure of the site and can start generating visibility and donations, we have to keep costs to a minimum and make do with the free tools available.

    So far I’m afraid your lack of understanding of the issue is not giving me much confidence and I may have to look elsewhere. I do, appreciate, though, your responsiveness.

    Hi Arthur,
    I didn’t noticed that were the same.
    I am doing some tests in our websites to understand what is happening and I will let you know.

    There is a bug with that shortcode on parsing integer and not just strings for the tax parameter.
    I am releasing a new version in few minutes.

    Thread Starter Arthur

    (@aahkendall)

    Thanks Daniele – it’s now working!

    Although one thing puzzles me, it was not working either for integers or strings – I have the slug as the parameter and tried the ID number, but neither worked. Anyway, I will now add some more terms and hopefully it will all be ok.

    • This reply was modified 1 year, 5 months ago by Arthur.
    Thread Starter Arthur

    (@aahkendall)

    It’s still not working for slugs. I don’t know why I hadn’t realised this, but under Microbiota there should have been one. I must have thought I hadn’t added the shortcode yet. But I had. However, if I put the ID, it does work.

    Thread Starter Arthur

    (@aahkendall)

    Also, the term count is still not updating, at least not using the manual update button. We shall see tomorrow if it updates using the cron job.

    So the term count is just a counter to show that the system found the terms and how many they are include the related terms. It isn’t used to inject terms or other stuff.

    I am testing now that shortcode with id and the full slug and is now working to me.

    [glossary-terms order="desc" num="4" tax=sottocategoria]
    [glossary-terms order="desc" num="4" tax=13]

    So in our dev system works. I think that is better we move to support {at} codeat.co with access as admin to that staging website.

    About the counter seems that manual update wasn’t working I will do a new release when all your issue will be solved.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘No terms appearing: term count not updating’ is closed to new replies.