Support » Plugin: Advanced Editor Tools (previously TinyMCE Advanced) » No tadv/classic-paragraph block

  • I recently upgraded the PHP on my WordPress host and in the process a few plugins were wiped out. Their folder in the plugins was empty after the update. TinyMCE Advanced being one of them. I’ve reinstalled, and verified the setting, “Add Classic Paragraph block” is enabled, yet I still get the following error when trying to edit existing posts, “Your site doesn’t include support for the “tadv/classic-paragraph” block. You can leave this block intact, convert its content to a Custom HTML block, or remove it entirely.” It seems that the re-install didn’t work for some reason. Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    Sounds like something is not loaded correctly. Do you see any missing files (404s) in the browser tools?

    If yes, try to determine why the files are not loaded. Are the URLs correct? Could it be server permissions (rare but not impossible), any errors in the web server logs, etc.

    In any case, try deleting and reinstalling the plugin again, then re-saving the settings.

    Thread Starter dwagg

    (@dwagg)

    Thanks for the tips Andrew. Unfortunately, neither of the first two seem to be the issue and re-installing did not work. I suspect my theme, “WP Knowledge Base”, is broken after upgrading to PHP 7.3 and the enqueue function isn’t working correctly to load the custom block from your plugin. I thought I had fixed it when I got it to clear the errors, but apparently not. I’m not a PHP programmer by any means. I’ll have to search out a new theme for the site and see if it fixes the problem.

    Plugin Author Andrew Ozz

    (@azaozz)

    Uh, sorry to hear that. If you suspect that some “old” PHP code is not compatible with PHP 7.3 it would be helpful looking at the server/PHP error logs and fixing any errors there first.

    If the theme is incompatible with PHP 7.3 perhaps there are other users that are experiencing similar problems. Maybe try to get in touch with the authors and see if they would fix it.

    Thread Starter dwagg

    (@dwagg)

    Upon further digging, I’m not sure it is a PHP problem. Seems the issue is only when working in Edge. Using Chrome sees the classic paragraph block just fine.

    I frequently get the same error — maddening! I don’t understand why it would depend on the browser.

    Alex

    My problem is similar if not the same: with Tiny MCE Advanced Active, attempts to edit classic paragraphs are responded to with a Block icon that I can’t identify (in the shape of a small rectangle with two small ‘marks’ on top that make it look a little like a car battery) and with the message ‘Your site doesn’t include support for the “tadv/classic-paragraph”block. You can leave this block intact, convert its content to a Custom HTML block, or remove it entirely.’…and that message is followed by a button labelled ‘Keep as HTML’.
    No editing of the text is facilitated.
    I would really appreciate any help or guidance with this issue.

    Me too. I am using “Twenty Twenty” theme. I have removed “Tiny MCE Advanced Active” and “Classic Editor”.

    I assume the HTML difference between this “tadv” and normal WP paragraph block is minuscule. Perhaps some advice on that might come in handy?

    HTML markup for “tadv” is only this:

    <!-- wp:tadv/classic-paragraph /-->

    no content. yes I have lost no content but this markup has stayed in just to annoy and waste some more time.

    Plugin Author Andrew Ozz

    (@azaozz)

    attempts to edit classic paragraphs are responded to with a Block icon that I can’t identify

    @continuumfp this means the classic paragraph block is “not defined”. Can happen if the Advanced Editor Tools plugin is deactivated, or perhaps if the checkbox to add Classic Paragraph is unchecked, see https://ps.w.org/tinymce-advanced/assets/screenshot-8.jpg?rev=2390186.

    I doubt it it’s any of the above but have a look just in case. If the plugin is enabled and “Add Classic Paragraph” checkbox is checked, re-save the settings anyway. There have been cases in the past where re-saving has helped.

    If still no change, please look in the browser tools for clues like js errors, files that are not loaded (error 404), files that are “forbidden” (error 403), etc. and post them in a new thread if any.

    @dbj support for the Classic Paragraph block is added by the Advanced Editor Tools plugin. It needs to be active and the checkbox selected for it to be loaded in the block editor.

    Not sure what happened with the blocks and why there’s no content. Perhaps there were/are some js errors? In any case, the Classic Paragraph block is almost the same as the Classic block (not the Paragraph block). If you edit the post in the Text editor on the old Edit Post screen, and delete both of the classic paragraph “delimiters”, the HTML code should get recognized as Classic block in the block editor. (Of course that’s a last-resort thing, backup your post before attempting it!)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘No tadv/classic-paragraph block’ is closed to new replies.