Support » Plugin: Search like Google Site Search, Amazon or eBay - WPSOLR » Self hosted solr configuration in oreder to work properly :D

  • Broken and not working for self hosted solr, Error in batch indexing in self hosted setup.

    Fix:
    =========

    1. Go to apache site and download solr version (solr-4.7.2) and extract to /opt/solr directory in root (/) dir and provide 755 recursive permission.

    3. install latest java jdk version, as solr needs java. needs sudo user to install.

    sudo -s

    provide sudo password to login. than you will be logged in as root user.

    install java jdk

    sudo apt-get install jdk

    confirm java installed

    javac or java –version

    3. change directory to solr

    cd /opt/solr/solr/bin

    3. start solr server

    java -jar start.jar

    4. locate your browser url

    http://localhost:8983/solr/

    you will be able to see solr admin , cool.

    5. Now you will need to fix

    /opt/solr/solr/collection1/conf/solrconfig.xml file

    open and change this ‘<luceneMatchVersion>4.7</luceneMatchVersion>’ to

    <luceneMatchVersion>4.6</luceneMatchVersion>

    It will match the luence version to our solr installtion setup. we are all completed now. if you will not do this it will throw error in indexing ‘lazy_load_error’ java.

    6. configure wpsolr with solr details:

    Index name: whateveer you want
    Solr Protocol: http
    Solr host: localhost
    Solr port: 8983
    Solr path: /solr

    And click “Check Solr Status, then Save this configuration” button a green arrow will show, means all cool. now check uncheck page,post ,cateogry , taxonomy to index, than go to “solr indexing batch” tab and
    click “Synchronize WordPress with ‘Config’ ” button it will index all new changes to solr.

    7. Search in custom pages or post:

    shortocde: [solr_search_shortcode]

    Hurry !! 😀

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Self hosted solr configuration in oreder to work properly :D’ is closed to new replies.