Support » Plugin: Customize Posts » No support for Page on Front

  • Resolved viewup

    (@viewup)


    The plugin doesn’t support pages listing another pages (eg page on front)
    When you edit a post listed on a page, the page is edited instead.

    Tested on WordPress 4.8 and Twenty Seventeen Theme

    How to Reproduce:

    1. On customizer, select a page on front
    2. On theme settings, select some content to be on the front page sections.
    3. When you try to edit the content with the plugin, the front page is edited instead.

    Also, try to put a blog page in a section. The posts listed cannot be edited too.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Weston Ruter

    (@westonruter)

    Thank you. I can reproduce this issue. It looks like an issue with nested partials. We’ll have to dig in deeper to figure out what is going on.

    Plugin Author Weston Ruter

    (@westonruter)

    @viewup I have a fix in a pull request. Would you be able to test? See https://github.com/xwp/wp-customize-posts/pull/355

    viewup

    (@viewup)

    of course. I will test it and give you a feedback

    viewup

    (@viewup)

    I’ve tested (wp-customize-posts-84a4f9ae39cf95f0215e17f658e36cf91ea3ec8c) and this is what happened:

    The partial posts cannot be edited anymore.But there is 2 other problems.

    First (in the image below), the WYSIWYG is on the screen everytime for some reason on editing the home page.

    Bug

    Second, i’ve lost the ability to edit any post. I can’t edit single posts or posts on a post list.

    Maybe this can help: On the current version, if you set a page to be a blog page, the posts listed inside it can be edited without any problem. Maybe this can be applyed to the homepage. But in this case, WordPress blocks any edit to the blog page, only allowing to edit the title. What you use to identify the post being edited (on a list)? how do you swap between the posts?

    • This reply was modified 3 months ago by  viewup.
    Plugin Author Weston Ruter

    (@westonruter)

    @viewup It looks like you haven’t run grunt build. That’s why things are broken. You can either run the build, or you can add define( 'SCRIPT_DEBUG', true ) in your wp-config.php.

    sorry about that, i will test it again

    Plugin Author Weston Ruter

    (@westonruter)

    No worries. It’s something we should try to do a better job of indicating that a build hasn’t been run.

    sorry, i have tried to clone the repo and install the dependencies, but i’m having this error:
    ERROR: Can't find config file: .jshintrc
    This is not related to the problem itself…

    Plugin Author Weston Ruter

    (@westonruter)

    @viewup make sure you first do git submodule update --init. The dev-lib submodule needs to be initialized because some files symlink into it, such as https://github.com/xwp/wp-customize-posts/blob/develop/.jshintrc

    I didnt use –recursive when cloing the repo. I did clone and install dependencies, run grunt. Not it works great! The problem is solved.

    I’ve notice one thing: The edit shortcut is not appearing on pages front sections.

    It appears if i set the blog on front page (to the posts) but wont appear to the normal pages.

    The pages can be edited clicking on the edit button, but the pen shortcut wont appear to the title or content (it appears sometimes after editing…)

    NOTE: I’ve set the Homepage as a front page section (on the home page). in this case, the pen is showing up, but other pages it wont appear.

    Print

    Besides this, is working great. Waiting the plugin update 😀

    • This reply was modified 2 months, 4 weeks ago by  viewup.
    • This reply was modified 2 months, 4 weeks ago by  viewup.
    Plugin Author Weston Ruter

    (@westonruter)

    Thanks for testing.

    I’ve set the Homepage as a front page section (on the home page). in this case, the pen is showing up, but other pages it wont appear.

    I see what the problem is there. It’s that each of the front-page panel pages aren’t queried via WP_Query and so they never hit the the_posts filter, and so Customize Posts doesn’t see it. This I’ve fixed on that pull request with https://github.com/xwp/wp-customize-posts/pull/355/commits/63ade23

    There was then a second problem with the edit shortcuts which manifest itself whenever you change one of the panels in Twenty Seventeen: the newly inserted post would lack the edit shortcuts until you reload the preview. This I’ve put in a fix on the same PR to dynamically re-add the edit shortcuts for any partial placement that appears inside of the mutation container: https://github.com/xwp/wp-customize-posts/pull/355/commits/9d39600

    Please test.

    A wild problem appeared:
    The edit shortcut now are showing and working. But when i edit the post content (or title) from a section in front, the pen disappear (from the respective edited field).

    This also happens in posts, but just one pen disappear.

    • This reply was modified 2 months, 3 weeks ago by  viewup.
    • This reply was modified 2 months, 3 weeks ago by  viewup.
    Plugin Author Weston Ruter

    (@westonruter)

    @viewup Good catch! I’ve identified the problem and fixed it in https://github.com/xwp/wp-customize-posts/pull/355/commits/27bfb82

    Would you confirm?

    Now Its great! Tested all the issues (and tested with jetpack with ajax posts enabled) and it works like magic!

    good job and thanks for fixing it!

    I will keep searching bugs and improvements.

    Waiting for the update!

    Plugin Author Weston Ruter

    (@westonruter)

    Thanks a lot for your great testing and feedback!

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.