Support » Networking WordPress » no superadmin menu on WP3 multisite install on dreamhost

  • Resolved rohit11

    (@rohit11)


    I’m trying to create a fresh wp3 install on dreamhost with multisite.

    # Default wp3 installtion is working fine
    # adding define( 'WP_ALLOW_MULTISITE', true ); in wp-config.php is enabling the network menu.
    # added further lines in wp-config.php & .htaccess as shown by network wizard
    # created blogs.dir
    # logged out & logged in

    At this point normally the “superadmin” menu should appear which is not happening.

    Note – I’m trying to do a subdirectory multisite install where the parent installation is on the root of domain & not in any other subdirectory. I have also removed www from the wordpress URL & site URL as asked by dashboard.

Viewing 15 replies - 1 through 15 (of 31 total)
  • Does your username contain an uppercase letter?

    nope, its admin only

    And who is your webhost?

    Other notes:

    – the lines you paste in the config file do not go at the bottom or the top. stuff them somewhere in the middle.
    – the htaccess rules *replace* anything you previously had, you don;t add them.

    DAMN!
    wp-config.php – lines were at end, moving them in middle of the file did the trick

    Webhost = dreamhost
    .htaccess = freshly brewed, there wasn’t any

    Thanks Andrea_r

    wp-config.php – lines were at end,

    At the end, past the “Don’t edit beyond this point” comment. 🙂

    According to this article, http://planetwp.net/2010/06/19/wordpress-3-0-multi-site-on-dreamhost/ :

    “Multi-Site is not supported on our shared servers. You will need a PS to enable the feature. You will also need wildcard DNS which also requires a PS.”

    I’ve successfully installed subdirectory WP3 Multisite on dreamhost
    I suppose the problem is with subdomain install.

    It is definitely true that they don’t allow wildcard DNS without a PS, but if you can correctly configure your DNS for each subdomain you want to setup on wordpress, I would think it would still work.

    That said, as soon as I completed the steps for a subdomain install, the network page changed to have instructions for a sub-directory install, and I can’t get it to complete using sub-domains.

    Hah, I’m a dork. I saw the first line for wp-config.php:
    define( ‘MULTISITE’, true );

    And I thought it was a repetition of what I had already added to the file:
    define(‘WP_ALLOW_MULTISITE’, true);

    After staring at it for about 15 minutes, I realized that it wasn’t the same. Wow, I’m quick…

    Seems to work, now to see if I can add a subdomain.

    According to this article, http://planetwp.net/2010/06/19/wordpress-3-0-multi-site-on-dreamhost/ :

    “Multi-Site is not supported on our shared servers. You will need a PS to enable the feature. You will also need wildcard DNS which also requires a PS.”

    It’s actually possible to use MS on a shared account on DreamHost. You just have to use the alternative process of manually creating the subdomain and making it point to your WP folder (as opposed to using the wildcard and letting WordPress do it automatically).

    However, you have to be responsible for doing that. The reason why DH requires PS is because of the memory usage (which is what they told me anyway) and apparently that stems from having 100’s of blogs. Having a few, maybe ~10 would be okay. Maybe.

    Just be aware 🙂 Hold no one responsible but yourself.

    I have dreamhost and have been having quite a few issues getting my multisite up. As a side note, I recently had it working fine on godaddy.

    I finally got it working after doing a complete reinstall bagging the DH one-click install and installing a fresh one from WP.

    But now, although my new site urls are finally properly formed, the pages just load a blank page. Is this due to DH not supporting multisite on shared?

    Blank page = php errors.

    Did you put in the new TwentyTen theme? New blogs use this by default. If it’s not there, white screen.

    @andrea it looks like having the P2 be my child theme for my sites is my issue.

    Can you help me understand what I need to do in order to get P2 to be the only theme avail for my child sites on multisite?

    Go to Super Admin -> Themes. Disable all the other theme. enable p2.

    Now, make it the default. Add this line to wp-config.php:

    define(‘WP_DEFAULT_THEME’, ‘p2’);

    Presto.

    Voila! That worked, thank you!

    However, all of the wp-signup pages lost all of their formatting? Is there an easy way to tell them to adopt the p2 css as well?

    Lastly, if I alter and make changes to this theme with the style.css, will all of my new sites adopt these changes I made or will they be given just a stock install of p2?

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘no superadmin menu on WP3 multisite install on dreamhost’ is closed to new replies.