WordPress.org

Support

Support » Multisite » [Resolved] No Super Admin: Warning: An existing WordPress network was detected.

[Resolved] No Super Admin: Warning: An existing WordPress network was detected.

  • Hi,

    I’ve been through this cycle 3-4 times with the same results:
    Problem: After installing site and getting Tools> Network to show; and editing wp-config and .htaccess, adding wp-content/blogs.dir:
    The SuperAdmin Menu does NOT appear and cannot set up network blogs.

    1) Running WP 3.01.;

    2) Edited wp-config.php as per instructions, above “That’s all…”: uploaded
    including: define(‘WP_ALLOW_MULTISITE’, true);

    3) Tools>Network
    “Warning: An existing WordPress network was detected.”

    4) Added to wp-config.php as instructed, Below ‘WP_ALLOW_MULTISITE’, true); above “That’s all” and uploaded:
    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, false );
    $base = ‘/’;
    define( ‘DOMAIN_CURRENT_SITE’, ‘www.previewresorts.com’ );
    define( ‘PATH_CURRENT_SITE’, ‘/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    5) Created .htaccess as per instructions: and uploaded;

    6) No security keys installed; no salts prompted

    7) I’ve recycled this by deleting all the files in the domain; deleting the database; created new databases; used the new database specifics in the config file.

    ANY IDEAS? How do I fix it?

    Thanks,

    HG

Viewing 9 replies - 1 through 9 (of 9 total)
  • Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    3) Tools>Network
    “Warning: An existing WordPress network was detected.”

    If you get this message then there is absolutely network-related files in the database. Continuing on with the remaining steps won’t force it to do anything different.

    Go back to a fresh clean WordPress install with a brand new database. Don’t do any of the network creation parts.

    Now go look in the db, specifically for these tables:
    wp_blogs
    wp_blog_versions
    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta

    Are any of them there?

    Also – you on a Windows server?

    Hi Andrea. Your legend precedes you! Thanks for being there.

    On a Linux server; shared account with 1and1;

    1) Deleted all files
    2) New Database; deleted old database
    3) Standard install of new WordPress 3.01; no network
    4) PHP Admin shows these tables Only:
    wp_commentmeta
    wp_comments
    wp_links
    wp_options
    wp_postmeta
    wp_posts
    wp_terms
    wp_term_relationships
    wp_term_taxonomy
    wp_usermeta
    wp_users

    It looks pretty clean. I want to do a subfolder network install. This domain is older than 30 days. It’s http://www.previewresorts.com. It was only a test site for a future move of my HTML site into WordPress for content management. Now I want to get this site up and running. For organization reasons, I want to separate our destination offers into their own subfolder, with their own content management.

    What do I do next???

    Thanks,

    HG

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    If it help, there’s plenty of people here with issues on 1and1.

    Add the line to config:

    define('WP_ALLOW_MULTISITE', true);

    I stick it in the middle, usually around the db collate.language, just cuz there’s a break there.

    Don’t do anything else yet – go look at the db again. Is it the same? It should be.

    Look at the Network menu item, it should show now. That’s all this line does is show that menu item. Does the Network say there’s an existing network? (it should not)

    (also I did all this up in a free ebook here:
    http://wpebooks.com/2010/09/how-to-enable-multisite-in-wordpress/
    )

    This domain is older than 30 days.

    the 30 day requirement is if the *install* is older than 30 days. If you dropped the database and started with a new one… then it’s a new install.

    Thanks Andrea,

    This is what I’ve done:

    1) Added: define(‘WP_ALLOW_MULTISITE’, true); to config
    2) Put it in right after “define(‘DB_COLLATE’, ”);”
    3) Saved and uploaded: replaced file
    4) Logged in
    5) Have Tools>Network now

    Before doing the new install you recommended above, I deleted all of the old site files; I deleted the database and created the new fresh database with the tables listed in the previous message.

    Thanks for taking this one step at a time with me. But, so far, this is exactly the process I used before posting the thread.

    HG

    Hi Andrea,

    After doing the above. I downloaded your instruction manual. I am back at the original problem I had that caused me to have to reinstall WordPress and the databases repeatedly.

    Help! I’m locked out and cannot log in. Passwords do not work.

    I followed the directions in your manual:
    1) Tool>Network
    2) Selected Subdirectories
    3) provided the name and admin email address
    4) Clicked through:
    5) Got the set-up screen: added the lines to the config; created the .htaccess with the code provided; uploaded;
    6) Hit the Log in button
    7) Tried to log in with the user password I gave when I created the site
    8) Password not recognized
    9) Hit “lost password”
    10) WP sent two emails:
    a) Password Reset been requested
    b) New password sent for “admin”
    11) New password failed.

    Help

    What’s next????

    HG

    By the way the database has these tables, in case you need them:

    wp_blogs
    wp_blog_versions
    wp_commentmeta
    wp_comments
    wp_links
    wp_options
    wp_postmeta
    wp_posts
    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta
    wp_terms
    wp_term_relationships
    wp_term_taxonomy
    wp_usermeta
    wp_users

    Andrea Rennick

    @andrea_r

    Customer Care at Copyblogger Media and Studiopress

    6) Hit the Log in button
    7) Tried to log in with the user password I gave when I created the site
    8) Password not recognized
    9) Hit “lost password”
    10) WP sent two emails:
    a) Password Reset been requested
    b) New password sent for “admin”
    11) New password failed.

    Don’t reset the password. Clear your cache & cookies. You can test this by using a different browser. 😉

    (I’ll add this bit.)

    Hi Huntergatherer I have same problem and in 1and1 too, can you explain how to resolve t?

    Many thanks

    elp20

    Follow Andrea’s instructions to the letter. You might want to start your own thread. She or someone as good will respond and help you. But, for my time, Andrea provides accurate information on solving these problems. It’s been a while since I had to reinstall everything.

    Good luck….good hunting..

    HG

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] No Super Admin: Warning: An existing WordPress network was detected.’ is closed to new replies.
Skip to toolbar