[resolved] [closed] No Super Admin Panel (37 posts)

  1. praeix
    Posted 6 years ago #

    I was attempting a Network install. I followed all the instructions explicitly, but when I logged back into the WordPress admin area after Step 5: Enabling the Network, there was no super admin panel.

    I then proceeded to research as much of this topic as I could. All of the WordPress "help" resources pointed me to double check everything that I just did. So I did that. The wp-config.php file is correct. mod_rewrite() is enabled through my hosting. The .htaccess file is 100% correct according to the instructions. The database tables exist and have proper permissions. The blog.dir directory exists and has proper permissions. But there is NO super admin panel that shows up.

    The only thing I haven't tried is a re-install. If anybody can help me out with this issue, I will greatly appreciate it.


  2. alm06130
    Posted 6 years ago #

    Super admin panel is displayed when is_multisite and is_superadmin are true (see wp-admin/menu.php).
    is_multisite return MULTISITE if defined (verify one more time!)
    is_superadmin return $current_user->id must be 0
    try to check these points.

  3. Jamie Welch
    Posted 6 years ago #

    Try logging in as the root administrator user on your account (usually admin, or whatever you created the blog with). Then you should see the Super Admin Menu. You can then go to the users menu and give yourself the Super Admin user privilege in Super Admin > Users.

  4. dgilmour
    Posted 6 years ago #

    ... when I logged back into the WordPress admin area after Step 5: Enabling the Network, there was no super admin panel.

    Yes, it's not where you log in that matters, it's the account you're using; it must be one with Super Admin rights.

  5. You can then go to the users menu and give yourself the Super Admin user privilege in Super Admin > Users.

    It was moved. You have to go to that particular user's profile to make them a Super admin.

    And in Step 5, you have to complete *all* those tasks. you should be forced to login again as the main blog's original administrator. That user becomes the super Admin.

  6. Per-Arne Hoel
    Posted 5 years ago #

    I have the same problem: No Super Admin panel.
    My test installation has only one user: me, all steps followed, no errors.
    praeix: Have you found a solution?

  7. Works for me, multiple times on different servers.

    check and see if the db tables were created.

  8. dsamorano
    Posted 5 years ago #

    same issue here no super admin....

  9. mpvanwinkle77
    Posted 5 years ago #

    Same issue. I also don't have Super Admin menu, nor do I have the ability t upgrade the Admin to Super Admin

  10. mpvanwinkle77
    Posted 5 years ago #

    Ok, fixed my problem by changing where in the wp-config.php I was defining the multisite settings. Try placing these:

    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'domain.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Right underneath the DB_COLLATE definition.

  11. A lot of people have been placing these commands at the bottom of the file. Right under the line where it says "That's it! Stop editing!"

    Anything under those lines does not get read.

    So yeah, stick 'em in the middle.

  12. dsamorano
    Posted 5 years ago #

    i tried the code above would not work either....

  13. @dsamorano
    are you following these steps, in order?

  14. meira
    Posted 5 years ago #

    I have the same problem. mpvanwinkle77 hack works for me. But user admin ID still 1, not 0.

  15. jameshsi
    Posted 5 years ago #

    I finally found the shXt problem caused the super admin no show, it is because the steps first ask you to add a line :
    define('WP_ALLOW_MULTISITE', true);

    and then after you enable the network, it ask you to add some more lines:
    and the first one is:
    define( 'MULTISITE', true );

    They looks very alike and I thought I have already add that one, and pass that line.

    Suggest move
    define( 'MULTISITE', true );
    to second line.

  16. Anyone reading along,please do not just paste these lines in your config file. You *must* visit the Network menu item and click the button that will add the needed tables.

  17. kieshute
    Posted 5 years ago #

    OK. I followed steps: http://codex.wordpress.org/Create_A_Network

    But... 'Super Admin' I can't find.
    I can't find what is wrong on my DB.

    How to completely remove the previous installation?
    Which files and directories must be delleted from root directory?
    Do I need drop these tables:

    and then I'll attempt to re-install, I hope this helps :)

  18. undo the htaccess and wp-config change you made. Drop those extra tables. Then you can set up the network again.

    make sure the quotes in those define are actually these kind: '

    and not the smart curly quotes Windows uses.

  19. kieshute
    Posted 5 years ago #

    OK. Thanks for the reply.
    One more question - bifore I installed 'Network' I tried different User-roles plugins, later I uninstaled those plugins.
    Can it be possible that I can't see Super admin panel because somewher in the 'wp_options' table left records from User-roles plugins?


  20. Possible, yes. Make a new account and make THAT one an admin as well.

    Then maybe we can copy the user settings (permissions/access levels etc) from that account to yours.

  21. kieshute
    Posted 5 years ago #

    I removed installation: dropped DB tables and removed extra lines in wp-config.php and .htaccess
    Also I edited wp_options and wp_usermeta tables to sett to default values - after, Network reinstallation whit no results - no Super admin panel.
    Created new account whit admin permissions THAT one an admin as well, and tried to install Network again - the same problem...

    Also I tried install Network on fresh clean CMS without any changes - the same result - when I relogin I can see only the "Dashboard"

    Any ideas?

  22. Really dumb question....

    To install network, you just add define('WP_ALLOW_MULTISITE', true); and then you get the rest of the data to add, right?

  23. and for giggles, try it with a user named "admin".

  24. kieshute
    Posted 5 years ago #

    I'm using administrator user named "admin".
    I understand that installation of "Network" is simple if all is going as designed by default. But, if it does not?
    In my case - I getting no errors during the installation, and it seems all is going right. Then why not only I, but also others have the same problem?
    I presume, the reason of this, is somewhere in server configuration...
    But I can't find any discrepancy whit "Server Requirements"

  25. kieshute
    Posted 5 years ago #

    to help identify the cause, I can give you required information, write only what you need...

  26. It's quite possible that you're on a host that runs a script to disable it from showing.

    They can do that. ;)

    What host are you on?

  27. kieshute
    Posted 5 years ago #

    I have dedicated server. I have root access to this server.

  28. I've done this on a few different servers - including naked dedicated boxes.

    99% of the time it's user error. I can't tell you any more than what I have, and to fix it, I'd have to go in and look (which I can't do).

  29. kieshute
    Posted 5 years ago #

    Thank you for your understanding.
    I presume, somewhere in the database must be Super admin options. As was mentioned - Super admin ID in wp_users table must be '0', but after Network install my admin ID still '1', and the changing to '0' - no result. It seems that my admin account stay on simple admin...
    What should I start looking for?
    Can you send me by email contents of database tables of fresh working Network? kieshute@gmail.com

  30. kieshute
    Posted 5 years ago #

    also I noticed that when a new account is registed the new user blog post is not created. In its control panel administrative tools are not created.
    Is that because of installation of Super admin is not finished?

Topic Closed

This topic has been closed to new replies.

About this Topic