WordPress.org

Support

Support » Installation » No such file or directory?

No such file or directory?

  • I did it all and it seemed to work ok. but i got this error and have no idea what it means or how to fix it! HELP!!! I dont think i need to upgrade i just downloaded it.
    🙂

    Warning: main(ABSPATHwp-admin/includes/admin.php) [function.main]: failed to open stream: No such file or directory in /home/bsquarer/public_html/REBlog/wordpress/wp-admin/includes/upgrade.php on line 5

    Fatal error: main() [function.require]: Failed opening required ‘ABSPATHwp-admin/includes/admin.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/bsquarer/public_html/REBlog/wordpress/wp-admin/includes/upgrade.php on line 5

Viewing 9 replies - 1 through 9 (of 9 total)
  • Delete all the files and upload a fresh copy of the WP package. Make sure all the files get uploaded and uncorrupted.

    I did it. and redid the config file. this is the link to the install file based on my server.
    http://www.bsquarerealestate.com/REBlog/wordpress/wp-admin/install.php

    i get the same error. All i did was ftp it to the folder … is there something missing? i checked the admin file is there.

    ——————————————————————————–

    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘bsquarer_WordPress’); // The name of the database
    define(‘DB_USER’, ‘bsquarer_admin’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘password’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    There is something completely wrong with what is visible at the link you gave. It should NOT display the wp-config file ever!

    I’d suggest delete everything and eventually find some pro help, it is difficult to tell what is wrong on that server.

    Don’t feel too bad. I’m having the same problem. I see from a Google search that this same issue is popping up everywhere. I’m not convinced that there’s something wrong with the files or permissions or server.

    Even so, I’m hoping WordPress support can offer some sort of solution… ?

    whooami

    @whooami

    Member

    if ANY php file is spitting back content like above thats an issue on the server. I dont care where, or how many times it happens.

    “..popping up everywhere”

    there may be 1000’s of wp installs on one shitty server.

    trust me, its happened.

    there was a rampage of posts a few days ago, all the same problem basically. Guess what, all the sites were on godaddy, and godaddy was eventually determined to be the source of the problem(s).

    I’m having the same problem. I have a dedicated server on HostGator.com

    hopefully someone can figure this one out. I’ve installed it using wget in the shell and also unzipping on my local drive and reuploading. same message. re-uploaded it 2 or 3 times as well. rg

    Hi,

    I had a similar problem with an install of wordpress.

    So I shelled into the box and checked my wp-config.php file; the formatting of the file seemed to be jumbled (I guess this happened when I’d ftped it?). I tried to ftp again but – same problem – the file was still looking pretty screwed up.

    Luckily I had another install of WordPress on the box so I was able to copy the wp-config.php from that install over to my new one. That seemed to do the trick for me. Hope this helps here.

    so I was able to copy the wp-config.php from that install over to my new one.

    Well, I must add that without editing that config file, if you are just using it unchanged in a second install… would result the complete erasing of your initial blog content!

    So, NO, don’t try it at home – as the commercials say 🙂

    Arrgh! Yes! Apologies. Should have added that I edited it, just keeping the formatting of the file.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘No such file or directory?’ is closed to new replies.