Support » Plugin: WP-Matomo (WP-Piwik) » No statistics is recorded after the latest wp-piwik update

  • I don’t know what could cause the problem.
    The statistics are shown in the wordpress panel so there is a connection between the plugin and piwik installation. The javascript code in the site is exactly the same as the code that piwik shows. I even reseted the plugin and configured it again but with no result.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author braekling

    (@braekling)

    You marked this as resolved… can you please tell some more details so your solution can also help other users?

    In general: If the tracking code is inserted as expected and also the connection between WP-Piwik and Piwik is working, you should check your Piwik setup, because WP-Piwik integrates the Piwik tracking code, only, and is not involved in the tracking itself.

    For setting up the auto archiving of reports in piwik (as detailed in here) I was using the following command
    /usr/local/bin/php -f /home/yourcpanelsitename/public_html/piwik/console core:archive --url=example.org/piwik/ > /home/example/piwik-archive-output.log
    however because of some conflict of php version or something, this has stopped working. Trying an alternative method:
    /usr/bin/wget "http://your-server.org/path/to/piwik/misc/cron/archive.php?&token_auth=XYZ"
    solved the problem.

    • This reply was modified 2 years, 7 months ago by  WebNashr.
    Plugin Author braekling

    (@braekling)

    Great, thx a lot! 🙂

    Another problem is that for the main site (in a multisite) there is no statistics recorderd. I see the following line in the tracking code
    var u="//statistics.mysite.com/libs/jquery/libs/bower_components/jquery-placeholder/libs/jquery/stylesheets/";
    while according to piwik tracking code it has to be only
    var u="//statistics.mysite.com/";
    This is only for the main site, subsites do not have any problem.

    • This reply was modified 2 years, 7 months ago by  WebNashr.
    Plugin Author braekling

    (@braekling)

    Which tracking type are you using?

    Can you try to call this link and check the URL there?

    https://demo.piwik.org/?module=API&method=SitesManager.getJavascriptTag&idSite=7&piwikUrl=&format=xml&token_auth=anonymous
    (Please replace the bold parts with your configuration, of course.)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No statistics is recorded after the latest wp-piwik update’ is closed to new replies.