Support » Plugin: Site Reviews » No stars in Google search results

  • Resolved gerske

    (@gerske)


    I use (the very nice) Site Reviews plugin and have numerous reviews from users of our photography course. I’ve filled in all Rich Snippets information in the plugin settings. I checked if everything is alright with the Google test page. No problems. However, the website still doesn’t show stars on the Google search results.

    I don’t understand why. How can I make sure that the stars (4.7 out of 5!) will be featured in the search engine results? Thanks for the help!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Gemini Labs

    (@geminilabs)

    1. The Structured Data Testing Tool shows that your page has errors:

    2. Since your reviews are not assigned to any specific page, they apply to your entire site. Since you have changed the schema type to “Product”, you are referring to your website as a product. However, I am unsure if this makes any difference to Google.

    3. Apart from the above, the Structured Data Testing Tool shows that the Site Reviews part of your page schema is valid. It’s important to note that Google does not guarantee that schema is shown, even if it exists. I suggest you use the https://search.google.com/search-console to track down any issues.

    Thank you for the help!

    1) I have fixed the error a week ago.
    2) I have changed the schema type LocalBusiness a week ago.
    3) I don’t see any issues in the search console.

    Any other suggestions to try? Wondering why I still don’t see stars in the Google results. ;-(

    Best regards, Gerske

    Plugin Author Gemini Labs

    (@geminilabs)

    After looking at your site again, I suppose “Product” IS the correct schema type as you had before as the site exists to purchase a single product and all of the reviews are for that product.

    I cannot say why the schema is not being used by Google. Perhaps because of the other “CreativeWork” schema you have on the page Google is not able to detect which is the correct one to use.

    However, while the schema is being generated correctly as shown by the Structured Data Testing Tool, I do not really have any further advise for you in regards to fixing this aspect of your SEO.

    • This reply was modified 1 year, 3 months ago by Gemini Labs.

    Will the plugin automatically generate the schema for all pages that the shortcode appears in?

    Plugin Author Gemini Labs

    (@geminilabs)

    @leoadhemartan No. You must enable the schema option on the shortcode to enable it. Please see the documentation for more info.

    Plugin Author Gemini Labs

    (@geminilabs)

    @gerske I have one more suggestion for you:

    https://stackoverflow.com/questions/20469445/why-aggregate-rating-isnt-understood-by-google

    Google generally does not display rich snippets for Organization rating markups, at least not at the present time. They do, however, show the rating rich snippet for such things as hotels, restaurants, local businesses, and products. So you can try using a different markup for your business if it’s appropriate and hopefully the rich snippet will be generated.

    Since you have an “Organization” schema on your website with essentially the same @id as the Site Reviews schema, perhaps this is why Google is ignoring the schema. On the one hand you are defining your website as an “Organization”, on the other hand, you are defining it as a “Product”.

    Site Reviews adds the @id tag to your schema (with the URL of the page as the value) when you have selected “Product” as the schema type. This is to allow it to link to the schema generated from Woocommerce (and other e-commerce WordPress plugins) products.

    Two things to try:

    1. Remove the @id from the Site Reviews schema.

    /**
     * Removes the @id from the Site Reviews Product schema
     * Paste this in your active theme's functions.php file.
     * @param array $schema
     * @return array
     */
    add_filter( "site-reviews/schema/Product", function( $schema ) {
        unset( $schema['@id'] );
        return $schema;
    });

    2. Remove the “Organization” schema from your website.

    • This reply was modified 1 year, 3 months ago by Gemini Labs.
    • This reply was modified 1 year, 3 months ago by Gemini Labs.

    Thanks for the great help!

    There seems to be a small error in the code in 1):
    The line add_filter( “site-reviews/schema/Product”, function( $schema ) { gives a
    syntax error, unexpected ‘;’, expecting ‘(‘

    I removed the Organization schema from the website by using this code:

    function bybe_remove_yoast_json($data){
    $data = array();
    return $data;
    }
    add_filter(‘wpseo_json_ld_output’, ‘bybe_remove_yoast_json’, 10, 1);

    Now I only have Product schema. Hopefully the stars will be in Google search results in a few days!

    Best, Gerske

    Plugin Author Gemini Labs

    (@geminilabs)

    Did you copy/paste the code completely/correctly?

    It works for me with no issues.

    You are right! I copy pasted the code from the mail I received via WordPress about your reply instead via this page above. And in the mail the code was incorrect because of formatting error of the “”.

    Thanks again. I will first try your code. If not successful, the seconde code.

    Have a great weekend. And A+ for your support.

    Plugin Author Gemini Labs

    (@geminilabs)

    Happy to help. Please do consider leaving a review for the plugin if you find it useful! 🙂

    Unfortunately neither of your two things to try seem to have an effect on Google. Still no stars. ;-( Very strange!

    Plugin Author Gemini Labs

    (@geminilabs)

    Since Google’s Structured Data Testing Tool shows that the schema is correct and the green preview button is visible showing a correct preview of the snippet as it should appear in Google Search results, I really do not have any other ideas to help you.

    Perhaps the following link will help you to troubleshoot, it also contains some interesting resource links at the bottom of the page so make sure you read those too.

    https://www.tassos.gr/joomla-extensions/google-structured-data-markup/docs/structured-data-not-showing-in-google

    SEO is sometimes a tricky beast to tame!

    Plugin Author Gemini Labs

    (@geminilabs)

    Someone else was having a similar issue where the schema looked correct in the Structured Data Testing Tool but no stars were showing.

    I finally solved the problem by changing the @id of Organization from @id: https://mywebsite.net/#organization to @id: #organization as before. I thought that they were equivalent but I noticed later that it prevented the stars from displaying. It works now.

    It seems they had conflicting @id tags in their other schemas which were being generated/created outside of Site Reviews.

    Perhaps this may also be of help.

    Thanks for the superb help! Really appreciated.

    I only have 1 schema (for Product) with id the same as URL. So there is only 1 id. See here: https://search.google.com/structured-data/testing-tool#url=digitalefotografie.nu

    Do you suggest I change the @id from an URL to a name?

    BTW: I installed Woocommerce for 1 product page. For (only) this page the stars do show in Google! However I would like to have the Site Reviews stars to appear on Google for the home page as well. So, any help for that is really appreciated.
    https://digitalefotografie.nu/fotocursus/cursus-fotografie/

    Plugin Author Gemini Labs

    (@geminilabs)

    This is not the correct thing to do. You are selling two different products on your website and the reviews are provided for those products, not for your website. Attempting to apply the ratings of the products to your homepage may be interpreted as misleading by Google when it crawls your website. If this happens, your website ranking may be penalised.

    Please see: https://developers.google.com/search/docs/guides/sd-policies

    You can always make use of another schema plugin (such as https://wpschema.com/) to add schema to your website which may improve your ranking on Google, you just have to be careful not to misuse your rating schema.

    • This reply was modified 1 year, 1 month ago by Gemini Labs.
Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘No stars in Google search results’ is closed to new replies.