• I chose this form plugin because it stated it offered SSL encryption – I just spent an hour setting up my form, and there is no option to secure the form with SSL. It does produce nice-looking forms fairly easily, however too many options are “paid only”.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor CaptainForm

    (@captainform)

    Hello,

    All of our forms have SSL encryption enabled by default. That is why there is no option in the interface to enable it – it just comes as a default.

    You can check it by inspecting the form URL. You will see that the form URL begins with “https”, which indicates that the SSL protocol is there. If you are looking at the URL of one of your website’s pages, that is something different. If you want to have your entire website served through SSL, you will need to set up your own certificate.

    Anyways, any communication that is sent through the form is SSL protected. Additionally, you can enable data encryption in the section My Account. This is also a free feature.

    Should you need more specific assistance, please let us know.

    Best regards,
    The CaptainForm Team

    Thread Starter meburke

    (@meburke)

    I have my own SSL certificate – that’s not the issue. I apparently was under the impression that the page this form resided on would be an “https” page, set by the plugin. I don’t see a URL for the form itself anywhere, so I don’t know what you’re talking about.

    Plugin Contributor CaptainForm

    (@captainform)

    Hello,

    Our forms are loaded in iframes. Iframes have their own sources, which are actually the URLs from where the content is loaded. Basically, iframes are pages within pages.

    Please have a look at this screenshot: https://www.screencast.com/t/GeKcCGjjfjn I inspected the form element on the page and got to the source URL of the iframe. All of our form URLs start with https://app.captainform.com/(…)

    Can you please send us the URL to your page? Maybe there are some resources loaded on the page through “http” instead of “https”, which causes the page to be displayed as unsecured. If you are more comfortable like this, you can open a ticket at support@captainform.com.

    Best regards,
    The CaptainForm Team

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘No SSL as advertised’ is closed to new replies.