Support » Plugin: Memphis Documents Library » No sorting

  • Resolved haans

    (@haans)


    Version 3.6.11:
    I can’t get sorting to work. I’ve created three folders and put a few documents in each, but no matter what settings I use under “Default sort options”, there is no apparent sorting of the files. They are displayed in different order in Chrome and Edge, and if I enable sorting bar and try to sort by file name, I get “no files found in this folder”. It appears to move to a default folder or something?

    /?page_id=196&mdocs-cat=mdocuments&att=none

    Any suggestions?

Viewing 15 replies - 1 through 15 (of 16 total)
  • (Unrelated: I’ve started translating the plugin to Norwegian. Great plugin, just what I was looking for.)

    Plugin Author bhaldie

    (@bhaldie)

    I’ll take a look at this issue, sounds like you have found a bug. Ill get back to you when I know more.

    I have requested you to be a Norwegian translator you can follow the thread here:

    https://make.wordpress.org/polyglots/2016/11/28/hello-polyglots-15/

    Great, thanks.

    (The translation is more or less done and posted in the system. I’m using it on my own site, and it’s working. There are however some phrases that are still in English, even though they are translated in the .po-file.)

    Plugin Author bhaldie

    (@bhaldie)

    Yeah I may have missed a couple of translations if you could list them for me I can fix them for you.

    Plugin Author bhaldie

    (@bhaldie)

    Okay I have found the bug and will fix it for the next version of mdocs. It has to do with WordPress permalink settings, if you are using the plain permalink setting you will get this issue.

    A new version should be out soon.

    Wrong post sorry 🙂

    • This reply was modified 2 years, 8 months ago by  bhaldie.
    • This reply was modified 2 years, 8 months ago by  bhaldie.
    Plugin Author bhaldie

    (@bhaldie)

    do you have cookies enabled on your browsers. Sort relies on cookies in order to sort.

    Let me know.

    Yes, cookies are enabled.

    Plugin Author bhaldie

    (@bhaldie)

    Next question is do you have the “Disable User Sort” button checked if not check it and try again.

    Let me know the results.

    Tried both settings, yes.

    Plugin Author bhaldie

    (@bhaldie)

    Can you inspect one of the sort buttons e.g. Name or Version or Download:

    I need to see the the th tag look like. Here is an example of a working th tag for the Download sort button:

    
    <th class="mdocs-sort-option" data-disable-user-sort="" data-sort-type="downloads" data-current-cat="mdocs-cat-3" data-permalink="https://example.com/?page_id=7867&mdocs-cat=mdocs-cat-3&att=none">Downloads</th>
    

    <th class="mdocs-sort-option" data-disable-user-sort="" data-sort-type="modified" data-current-cat="mdocuments" data-permalink="http://www.example.com/?page_id=196&mdocs-cat=mdocuments&att=none">Sist endret <i class="fa fa-chevron-up"></i></th>

    Very strange. It suddenly started working, sort of, but there are still bugs. I didn’t really do anything, but now I can sort by pressing the different sort buttons. Setting the default sorting in the control panel still does nothing, though. It appears to remember the last chosen sorting, but there’s no difference if I choose file name or date, or ascending or descending in the settings. Tested in both Chrome and Edge.

    • This reply was modified 2 years, 8 months ago by  haans.
    Plugin Author bhaldie

    (@bhaldie)

    Try updating to the latest version of mdocs version 3.6.12 then goto the mdocs dashboard>Options>Settings>Default Sort Options and check both Disable User Sort and Hide Sortbar.

    Then goto your main site again and the mdocs document list page and open Chrome Inspect. Click on the Application tab at the top of the window.

    Under Storage Cookies delete the mdocs-sort-range and mdocs-sort-type cookie values.

    Refresh the page.

    This is getting stranger by the minute. Now it works if I check “Disable user sort”, but if I uncheck it, it reverts to (probably) the last used user sort method.

    Plugin Author bhaldie

    (@bhaldie)

    That sounds like the correct behaviour, disabling user sort does not use the saved cookies so when you check that method the settings for your default sort will work.

    So depending on your settings and the browser you use the sort will be different.

    Great, thanks. Seems to be working as it should now!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘No sorting’ is closed to new replies.