Support » Theme: Customizr » No smooth scrolling

  • Hi!

    I am using customizr pro. In Customizer/General Options I activated “Smooth scrolling”. Then I created a page with blocks featuring anchor IDs. Then I created menu links to those anchor IDs. When I click on a menu item which is a link to an anchor, the browser jumps immidiately to the anchor – no smooth scrolling at all 🙁

    When I click on the “Up” button on the reight side, it perfectly scrolls very smooth to the top of the page …

    How can I activate smooth scrolling for my anchor links? Is there something extra that I have to do besides switching on “smooth scrolling” in the global options?

    Best regards,
    Alex

    PS: I know that in the latest version the scope of smooth scrolling has been reduced to the #content area, but this is perfectly the case here, the anchor IDs sit right in the middle of the page.

    • This topic was modified 10 months, 2 weeks ago by faglork.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Theme Author Nicolas

    (@nikeo)

    Hello,
    Thanks for reporting your issue on the forum.
    I’ve tried to reproduce the problem but it works for me.
    I enable the “Smooth scroll on click” in the customizer ▸ Global settings ▸ Formatting : links, paragraphs …
    Then I create an anchor in a block of a post as documented here : https://wordpress.org/support/article/page-jumps/
    And finally I add an anchor link in the menu

    Thread Starter faglork

    (@faglork)

    Hi!

    That is exactly what I did. Look:

    https://www.pretzfelderkeller.de/

    click on Startseite -> Öffnungszeiten

    -> no smooth scroll 🙁

    once you’re down there, in the right bottom corner is the UP button. THIS works …

    Alex

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No smooth scrolling’ is closed to new replies.