Support » Plugin: Slideshow » no slideshow shows up

Viewing 10 replies - 1 through 10 (of 10 total)
  • Fabian,

    I just had a look at the page you were talking about, but I couldn’t see anything other than your camera/logo, the navigation bar and then the social/share buttons at the bottom.

    When you added the slideshow to this page, what is the text that shows in the visual editor?


    Hi Ryan,

    Thanks for having a look. Yeah, that’s the same I see. But the text in the visual editor says: [slideshow_deploy id=’1560′]
    And I uploaded a slideshow with this parameter. Any idea?
    Here’s the link again:

    Thanks a lot!


    Fabian can you try switiching back to the default theme (Twenty Thirteen or Twelve) and then looking at that page and seeing if the slideshow shows up?

    Plugin Author Stefan Boonstra


    Hi Fabian,

    Your “footer.php” file may not be included on the page yet, as the slideshow’s scripts and styles have not been loaded onto the page. You can check this by seeing if your theme’s “index.php” file calls the “<?php get_footer(); ?>” function.

    If it doesn’t contain this function, “footer.php” will not be included and the slideshow’s script won’t be loaded onto the page.

    As Ryan said, temporarily switching to the TwentyThirteen theme should indicate whether or not your current theme is set up correctly.

    Best regards,

    Thanks for helping me out, Ryan!

    thanks guys. I checked with the standard theme and it worked. Then I switched back to my theme and tried the slideshow in a posting and it worked. The problem seems to be that I want to have the slideshow on a “portfolio”-page, which seems to be a feature that is only used in the portfolium theme. Any idea, if I could use any code to get this “portfolio”-page, which is quite similar to a normal page, get the slideshow loaded?
    @stefan: The index calls the footer correctly…

    this is the single portfolio script:

    <?php get_header(); ?>
    <?php if ( have_posts() ) : ?>
        <?php while ( have_posts() ) : the_post(); ?>
        <div class="container clear">
            <div class="content">
                <div id="show">
                        $args = array(
                            'post_type' => 'attachment',
                            'orderby' => 'menu_order',
                            'order' => ASC,
                            'numberposts' => -1,
                            'post_status' => null,
                            'post_parent' => $post->ID,
                            'exclude' => get_post_thumbnail_id()
                        $attachments = get_posts($args);
                        if ( $attachments ):
                            foreach ( $attachments as $attachment ):
                                echo wp_get_attachment_image($attachment->ID, 'full');
            <div class="l_col">
                <div class="post_portfolio">
                    <p class="post_divider">—</p>
                    <div class="post_text"><?php the_content(); ?></div>
        <?php endwhile;?>
    <?php endif; ?>
    <div class="recent clear">
            $term = get_term_by('slug', get_query_var('term'), get_query_var('taxonomy'));
                    'post_type' => 'portfolio',
                    'works' => $term->slug,
                    'posts_per_page' => 10,
                    'post__not_in' => array($post->ID)
        <?php get_template_part('loop-portfolio');  // Loop template for portfolio (loop-portfolio.php) ?>
        <?php  wp_reset_query(); ?>

    [Please ALWAYS use the code buttons to post code on the forums]

    Update: If I add the <?php get_footer(); ?> to the portfolio php, the slideshow shows up, but just as a thumbnail. Could it be that the parameters in the stylesheet avoid a larger display?

    What size have you set the slideshow to be?

    At the moment it looks like you’ve only set it to be width: 145px; height: 400px; and so that’s what it’s displaying.

    Look in the slideshow you’ve created for this, go to display settings and see what the maximum width is and what the slideshows height is.

    @stefan – No problems, looked like something I could help with so glad to jump in for a bit!!

    Plugin Author Stefan Boonstra


    The slideshow is placed in an element with the “l_col” class. This element is set to be 145 pixels wide, which causes the slideshow to be 145 pixels wide as well.

    Yeah, Stefan! That’s it!!! Really great! Appreciate your help very much guys. Hard for a beginner to get stuff like this fixed… Will check finetuning the next days and get this thing going. You made my day! 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘no slideshow shows up’ is closed to new replies.