WordPress.org

Forums

[resolved] No slideshow in freshly installed theme (11 posts)

  1. zynov
    Member
    Posted 3 years ago #

    Disease info:

    Patient: WP - Academica theme http://demo.wpzoom.com/?theme=academica
    Patients website: http://www.kapap.home.pl/wp
    Symptoms: Slideshow not showing slides
    Diagnosis:

    Catchable fatal error: Object of class WP_Error could not be converted to string in /wp/wp-content/themes/academica/functions/wpzoom-functions.php on line 328

    If any of the WP doctors ;) here could help, it would be greatly appreciated.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Looks like the patient needs to try a new theme.

  3. zynov
    Member
    Posted 3 years ago #

    Is it that bad? Any other cure?

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    You could re-administering a fresh copy of academica in the hopes that it's simply a corrupted theme download. But, if that fails to fix the problem, then you need to start looking for another theme.

  5. zynov
    Member
    Posted 3 years ago #

    Hmmm... strange it is. I tried administering another theme (Jenks), which contains a slideshow and there was a problem too. As Jenks doesnt offer an option of previewing the slideshow in admin, I was not able to extract a similar error message. The slideshow just didnt show up. Someone told me there is a problem in WP files, not the themes itself. I have tried reinstalling WP (English and Polish versions, few times), but no improvement to patients health was observed whatsoever.

    I am looking for another theme at the moment if there is no option to cure the disease with known meds

  6. zynov
    Member
    Posted 3 years ago #

    OK, changed the theme for a working one, so consider the topic as solved (although the problem of a slideshow in Academic theme isnt solved)

  7. saz25
    Member
    Posted 3 years ago #

    Hi,
    Have you figured out how to configure the Academica slideshow? The online documentation doesn't match the theme's configuration pages. Are you using version 1.2 of Academica as I am?

    I think I am having trouble configuring the slide pages and what the various fields mean.
    Thanks in advance,
    Steve

  8. zynov
    Member
    Posted 3 years ago #

    Hi there, I havent... I just used another theme (Boldy) wchich is by far better than Academica.

  9. saz25
    Member
    Posted 3 years ago #

    Hi,
    Thanks.
    I'll try that too. Great tip.
    thanks again,
    Steve

  10. mattb3476
    Member
    Posted 3 years ago #

    I had the problem / confusion zynov first mentioned. I posted in the WPZOOM help forums and a moderator, Dumitru, helped me resolve the issue.

    WPZOOM help forums: http://www.wpzoom.com/forum/index.php

    I would recommend anyone with the theme go there, because I included pictures in my post.

    The post:
    http://www.wpzoom.com/forum/viewtopic.php?f=133&t=6107&p=24673#p24673

    But, here's some info.

    ***ME***

    I am having the same problem with the Academica slideshow as this guy, as well as others that I have read on the WordPress forums.

    After a fresh install of both WordPress and Academica, I cannot get the slider to work. I have followed the minimal documentation, but with no success.

    Others with the problem: http://wordpress.org/search/academica?forums=1

    Error given when I try to click to "view" a slide from the Slideshow slide list:

    "Catchable fatal error: Object of class WP_Error could not be converted to string in /home/content/09/8614809/html/wp-content/themes/academica/functions/wpzoom-functions.php on line 328"

    Site URL: Only an "in construction" page is up currently, which displays on an alternate theme. I am using the Theme Test Drive plugin while I set up Academica. I have troubleshot my problems without the plugin enabled and all issues were the same. This is a hired job, and I cannot have a development site public.

    Theme Test Drive: http://wordpress.org/extend/plugins/theme-test-drive

    WordPress version: 3.2.1

    Theme Versions: Academica 1.2

    Here's what I did.

    I enabled the slideshow and selected for two frames.

    Image

    I added two slides.

    Image

    But when I click to view the slide, I get the error given above.

    Image

    And when I look at the source code for my homepage, there is nothing for a slideshow.

    And, fyi, the documentation for the slideshow seems inaccurate.

    Here's a screen grab.

    Image

    This is what I have.

    Image

    For the slide options, there is only a box for a "slide link." No "Slide Type" drop box or anything else.

    ====================

    ***MODERATOR***

    Open /functions/wpzoom-functions.php and find these lines (#328):

    Code:
    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');

    Replace with:

    Code:
    if ($cat) {
    echo get_category_parents($cat, TRUE, ' ' . $delimiter . ' ');
    }

    See if this helped.

    ====================

    ***ME***

    Thanks again for the speedy reply, Dumitru!

    I replaced the line you said. Now, when I click "View Slideshow Item,"

    Image

    a page comes up, but the slide image is not displayed.

    Image

    I have checked the link in the "Slide Options" "Slide Link" box, and it is correct. For kicks, I also am using an image with the same dimensions as the slideshow on the Academica Live Demo - in case it needs to be exact.

    Also, I don't see anything in my homepage source code for the slideshow.

    In the WPZOOM Live Demo, it follows the closing of the header div.

    Image

    There's nothing in mine.

    Image

    ====================

    ***ME***

    I got the slideshow wrapper to show up on my homepage. But, the images aren't there yet.

    In the "Reading" settings of the WordPress "Settings" bar, the "Front page displays" setting needs to be set to "your latest posts." If it is set to a static page, the slideshow container doesn't show up.

    Image

    Image

    I had set it to my "homepage" page, since I want a static page as my homepage, rather than posts.

    But, it looks like you need to do this only in the WPZOOM "Theme Options."

    Image

    ====================

    ***MODERATOR***

    When you create a slideshow item and set a featured image for it, it isn't shown on the page for the slideshow item (when you open it).

    You still have to insert it into the content body for the custom post, we don't enforce it to be displayed, as many customers prefer to keep it just on the homepage.

    If you don't provide a link to your website, we can't help much.

    ====================

    ***ME***

    Thank you for your help, Dumitru. I'm all set up!

    I am a videographer building a small business website. I am a competent hobbyist with web design and WordPress, but by no means is it my territory.

    For those having who have trouble with the same things I did, here's a little more information. It's embarrassing, but I'll admit that it confused me!

    When setting up a slideshow,

    Image

    the "Slide Link" in the "Slide Options" panel is what the slide links to when it's clicked. It's NOT a link to the slide to be included in the slideshow.

    Image

    Each slide is created by making separate slides with "Add a New Slide"

    Image

    and uploaded through the featured image panel in the "Edit Slideshow Item" page.

    Image

    If it uploads correctly, you'll see it in the content display of the page.

    Image

    I think the confusion for me came from the documentation, which did not mention the "Featured Image" panel and made it seem like all the slide information was contained in the "Slide Options" panel.

    Image

    Adding to the confusion is that the "Slide Options" panel in the documentation is for a video and includes an interface that does not resemble the one in the template.

  11. snatcherandyjones
    Member
    Posted 3 years ago #

    Hi can anyone help me with this theme also? I would like to simply have the navigation bar below the slideshow (not at top of page).

    Can this be achieved simply?

    Andy

Topic Closed

This topic has been closed to new replies.

About this Topic