Support » Plugins and Hacks » No sitemap is created after activating XML Sitemaps

No sitemap is created after activating XML Sitemaps

  • WordPress version: 3.4.2
    WordPress SEO version:

    I did this: Activated XML Sitemaps

    I expected the plugin to do this: Produce sitemap

    Instead it did this: There is no sitemap. The sitemap us not found and does not exist. This happens with every sitemap plugin I try. There is no error message but no sitemap is created. Am running W3TC.

    Any help appreciated.


Viewing 15 replies - 1 through 15 (of 30 total)
  • Same here – hovering over the button says it will link to http://www.sitename.co.uk/sitemap_index.xml but there is no file there.

    Roger Sparks


    Exact same problem with same symptoms. Tried everything.

    WordPress 3.4.2.
    Wordprss SEO

    WordPress version: 3.4.2
    WordPress SEO version:
    WordPress Network: enabled
    No other SEO/XML plugin installed.

    I visited the SEO: XML Sitemaps page, the box was already checked so I clicked save. Nothing. No xml page was created.

    So I unchecked the box, clicked save, then re-checked the box and clicked saved and it the XML page is active now.

    before you create the sitemap you must click on the save button at the bottom,


    Roger Sparks



    I guess I wasn’t clear. I did exactly as you said and exactly the steps required. Multipole times.

    1. I visited the SEO XML Page.
    2. I unchecked the Check this Box to Enable.
    3. I selected the Save Settings button.
    4. The XML Sitemap Options dissapeared.
    5. I checked the Check This Box to Enable.
    6. The XML Sitemap Options reappeared,
    7. I selected the Save Settings button. (No Error)
    8. The You Can Find Your XML Sitemap Here with the XML Sitemap button appeared.
    9. I selected the XML Sitemap button. I got an error that the file sitemap_index.xml was not there.
    10. I examined the root directory with FTP. The file sitemap_index.xml was not there

    There is no file being created, and I got no error. I followed the instructions exactly – multiple times.

    I am in exactly the same position as Roger and have tried the same things, but no Sitemap.

    Roger Sparks



    I have been unable to get the XML sitemap – sitemap_index.xml – to generate. I have disabled the function, and installed the Google XML Sitemaps plugin instead. It installed and generated a sitemap without a problem in a few seconds.

    I would, however, prefer to use the sitemap in the Yoast SEO plugin, because I love everything else about the Yoast SEO plugin. Hopefully, whatever the problem is, it will get resolved and I can try it at a later time.

    Thanks for the help attempts from everyone.

    Roger: Thank you!

    Google XML Sitemaps worked after I unclicked save as gz. It errored out twice before doing that. Weird, eh?

    Thanks Roger, I have just done the same and it is looking good. 😉

    Just started using Yoast SEO after I saw a mention about a connection with Genesis which I use, and Genesis say their SEO is disabled if most other SEO plugins are installed.
    Well,the XML Site map was produced but was shocked to find in Google’s Webmaster Tools that only one page was indexed and the Sitemap produced contains urls which are blocked by robots.txt x 333. Obviously this is not a good start for a newly launched site. Any suggestions?

    I’ve got the exact same problem as Roger & other, no XML sitemap has been created. I’ve tried switching this setting off and on again just as Roger did but nothing!

    Did you guys click the XML Sitemap button next to where it says “You can find your XML Sitemap here”, or are you just looking for the file in your FTP? The domain/sitemap_index.xml file itself does not seem to actually be in the root of the site as implied by the URL. When I click that button, I see my sitemaps, and that URL appears in my browser – but I don’t see the xml file in my http://FTP..

    Otherwise, it sounds like maybe this plugin needs certain folders to be writable, and perhaps they are not depending on your individual sites. I have no idea which folders those would be though.

    Hi Ken,

    Yes I clicked on the “You can find…” button. Got a “Page not found” error.

    You could be right about the permissions, however I had the same problem with a localhost site running under XAMPP and an unrelated live site. I suspect there is more documentation needed by the developer. Sad that he hasn’t replied yet.

    Roger Sparks


    The net-net on this for me is this:

    1. I did everything than was required, multiple times, and it didn’t work.
    2. The sitemap_index.xml is supposed to be in the root directory – the link, created by the Yoast plug-in – that displays the file is looking for it in the root directory, so obvivously it thinks it was created there. It was not.
    3. There are no permissions problems – the other sitemap plug-in I ended up using – Google XML Sitemaps – had no problem creating their sitemap.xml file in the root directory. I also successfully linked to it from google and bing without a problem.
    4. I am doubtful that there is any conflict with another plug-in, since this is a very straightforward wordpress site. We only used two other simple plug-ins – Contact Form 7 and NextGEN Gallery – and neither should conflict in any way.

    So, it looks like the Yoast SEO plug-in has a problem. As I said, I am still using it – it is the best SEO plug-in – and wish I didn’t have to use another plug-in for the sitemap, but it is just not working for me, and it sounds like for others.

    I would love to hear from Yoast with a fix for whatever the problem is.

    Two Similar problems…
    #1. It appears to generate an xml file but the page – domain/sitemap_index.xml – is completely blank. If I view the page’s source code I see this…

    <?xml version=”1.0″ encoding=”UTF-8″?><?xml-stylesheet type=”text/xsl” href=”http://example.com.au/wp-content/plugins/wordpress-seo/css/xml-sitemap-xsl.php”?>
    <sitemapindex xmlns=”http://www.sitemaps.org/schemas/sitemap/0.9″>
    <!– XML Sitemap generated by Yoast WordPress SEO –>

    #2. Just checked another site and when I click on ‘view sitemap’ i get a 404 error. So the original plugin generated sitemaps I have submitted to google in google webmaster tools are throwing a ‘not found’ error obviously.

    All were fine initially when installed – sitemaps generated without a problem – but there’s been a few plugin upgrades since – I’ve simply just upgraded via backend and never thought to check the sitemap functionality.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘No sitemap is created after activating XML Sitemaps’ is closed to new replies.