Support » Theme: OceanWP » No Sidebar on Home Page

  • Resolved JKEngineer

    (@jkengineer)


    I cannot get a right (or left) sidebar to show on the home page of the site. I’ve got it the way I want it on all the other pages. I’ve looked through all the options in the customizer and do not find anything specific to this issue.
    In the Support Forums, I see one post that was sort of related, but is primarily relevant because it shows a sidebar on the home page.

    All help appreciated!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hello,

    I checked your site but didn’t see the sidebar on your homepage. Is it fixed?

    Hi Amit,
    No, the problem is that I can’t get the sidebar onto the home page. I’ve looked throughout the customizer and in the page definitions.

    In the Customizer, I only see the selection for sidebars in the Customizing >General Options >General Settings and that does not seem to affect the home page. There are no applicable choices in Customizing > Homepage Settings. However, I am using a static home page. I just tested using “your latest posts” as the home page and that does display the sidebar. Reverting to a static home page loses the sidebar again.

    In the Edit Page screen, the side panel only has Default Template and Landing Page options. I’ve used the Default Template. This is true for the Quick Edit of the page as well. These are the same options that are available for other pages, where I have also selected the Default Template.

    Hello,

    Edit the home page > oceanwp settings metabox > main tab and select sidebar layout. Without seeing the site settings, it is difficult to tell the exact reason.

    I am not sure where you are pointing me.

    In Dashboard>pages>edit page, there is nothing that refers to oceanwp. There is a drop down box for Template. It’s only choices are default template and landing page. I am using default template.

    In Dashboard>pages>quick edit, the same is true.

    In Customizer>Home Page Settings, the only things available are a radio button choice for whether the home page is latest posts or static, a drop down to select the name of the home page, and a drop down to select the name of the posts page. In addition there are two links for New Page under each of the last two items.

    I do not see anything resembling what you are suggesting.

    In Customizer>General Options>General Settings, which does not seem to be where you are pointing me, under Pages there is a graphic selection for the sidebar type and layout. I have right sidebar selected there and under Custom Sidebar as well.

    Please clarify your instructions. Do I have a corrupted copy of OceanWP that is missing some features? I am using the free version.

    Let me know if you need screen shots.

    Have you installed the Ocean Extra plugin? The settings I mentioned will appear only after the ocean extra activated.

    It was already installed and active.
    I tried deactivating and activating it again. No change. I checked the theme panel and sub-menus, everything is enabled.
    On the plug in wordpress.org page, the screen shots show elementor installed. I do not currently have it installed. Is that a contributory factor?

    When you say: “Edit the home page > oceanwp settings metabox > main tab and select sidebar layout.” are you referring to the customizer or the Dashboard>pages menu? I’ve tried both and do not see what you are describing.

    No, I’m referring to oceanwp page level settings. Go to Dashboard > Pages and edit the home page > oceanwp settings metabox (below the editor) > main tab and select sidebar layout.

    That did it.
    I just hadn’t scrolled down that far. I did not realize that there was all that extra stuff at the bottom.
    Thanks.

    You’re welcome

    oursimplicityproject

    (@oursimplicityproject)

    I am having the same issue and tried to follow the above but (Go to Dashboard > Pages and edit the home page > oceanwp settings metabox (below the editor) > main tab and select sidebar layout.) but I do not have a home page show up as an option in my dashboard under pages. It only shows my other pages. Any guidance would be much appreciated! Pulling my hair out..

    @oursimplicityproject can you share your site link so that I can check it?

    oursimplicityproject

    (@oursimplicityproject)

    Go to Customize > Blog > Entry and select a layout to fix it.

    oursimplicityproject

    (@oursimplicityproject)

    Brilliant! That worked, thank you Amit!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘No Sidebar on Home Page’ is closed to new replies.