WordPress.org

Forums

[resolved] No showing up (29 posts)

  1. Mateusz1
    Member
    Posted 2 years ago #

    Hi.

    Firstly link to my site

    Soo, the problem is that site is in the internet about 3 weeks with seo end sitemap plugin and nothing! I was verifed my side in google webmaster tools and nothing, of course in wordpress panel i had chose option "let index".

    This is not my first side in wordpress but i had first time problem like this!

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    What problem? Do you mean your site is not indexed by Google? If so, submit a sitemap at Google Webmaster Tools and look for results.

  3. Santosh
    Member
    Posted 2 years ago #

    question is not clear what you want

  4. Mateusz1
    Member
    Posted 2 years ago #

    I'm sorry. Of course I talk about not indexing my site in google. Yesterday i make Google Webmaster Tools account, verified my domain and added manualy sitemap (i mean link mydomain.com/sitemap.xml).

    Also i had active a plugin which make auto sitemaps (and seo plugin) but domain still is not indexing. I had on my others websites same plugins, same hosting and same domain registrator and the other ones are correct indexing.

    Site map of this no indexing site: link

    Also anothers serch (like bing or yahoo) dont see this site too, see only one link .../feed !

    What is wrong with this, any ideas?

  5. Santosh
    Member
    Posted 2 years ago #

    wait for 2-4 days it will show is google search results. For yahoo and bing you can submit your site to theme also

  6. Mateusz1
    Member
    Posted 2 years ago #

    You think? Ok so i waiting, but i'm afraid of that becouse site with all seo and sitemaps plugins is active over 3 weeks and nothing but maybe manually added site map willbe helpfull... hope so :).

    In wordpress menu i chose option "let index" but possible maybe is that i had blocked this elsewhere or not?

  7. Santosh
    Member
    Posted 2 years ago #

    give me your website link

  8. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    This is where you blocked search engines from indexing your site (see lines 18 and 19 of this report:

    <meta name="robots" content="none" />
    <meta name="googlebot" content="none" />

    Change them as:

    <meta name="robots" content="index,follow" />
    <meta name="googlebot" content="index,follow" />
  9. Mateusz1
    Member
    Posted 2 years ago #

    Thanks. Can i change this without html code change (i'm not computer science :) )? And you have idea why code is like this, i had few wordpress sites and always was indexing correct.

  10. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    And you have idea why code is like this

    For the meta tags (code) that you are currently having either look at the lines at the links I gave above, or inspect it at your site using Firebug + Firefox.

    The correct metatags to be inserted are also above. In fact you don't need the two lines. You can insert just:
    <meta name="robots" content="index,follow" />

  11. Santosh
    Member
    Posted 2 years ago #

    edit header.php

  12. Mateusz1
    Member
    Posted 2 years ago #

    Ok i try change the code (hope that i will not destroy anything :) ).

    For the meta tags (code) that you are currently having either look at the lines at the links I gave above, or inspect it at your site using Firebug + Firefox.

    In this theme is meta options (i off this becouse i had SEO plugin with the same options). This may be this?

  13. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Change the robots options as I suggested above in the theme options also, if you have one like that.

  14. Mateusz1
    Member
    Posted 2 years ago #

    Looool. Guys i found problem!

    This theme had "meta options" i turn off active meta keywords and descriptions becouse all in one seo pack have the same options, but next was:

    "Active Robots Indexing Option" of course i choose it but i don't see two options more:

    Choose General Bot Indexing Type
    and
    Choose Google Bot Indexing Type

    In this options i can chose: none/ index,follow/ index,nofollow/ index,all/ index/ index,follow,archiwe/ noindex,follow/ noindex,nofollow

    Of course smart theme choose automaticly "none" and that was problem i think, i chose now "index,all" both and code is now:

    <!-- robots -->
    <meta name="robots" content="index,all" />
    <meta name="googlebot" content="index,all" />

    You think that "index,all" will be best option for SEO or maybe i schould off this "Active Robots Indexing Option" (maybe it will be fight with seo plugin)?

  15. Santosh
    Member
    Posted 2 years ago #

    If you have some content that you don't want to show google than add that in robot.txt file

  16. Mateusz1
    Member
    Posted 2 years ago #

    Like what for example? :) And what is this follow and nofollow?

    And will in code is not nothing about "robot" how google treats code without that? Becouse my other site have not nothing about robots in html code.

  17. Santosh
    Member
    Posted 2 years ago #

    link some downloadable files actually you will have robot.txt file on other website

  18. Mateusz1
    Member
    Posted 2 years ago #

    I had robot.txt (but no blocked links in google webmaster tools) but had not the fragment of the code which we have problem here:

    <!-- robots -->
    <meta name="robots" content="index,all" />
    <meta name="googlebot" content="index,all" />

    This is necessary fragment for good SEO? Or any informations about googlebot and robots is good too?

  19. Santosh
    Member
    Posted 2 years ago #

    robot.txt is for blocking search engines from crawling your website. it don't have any importance in SEO. don't worried about it

  20. Mateusz1
    Member
    Posted 2 years ago #

    Ok thanks a lot for help, I hope now google fast added my site :).

  21. Santosh
    Member
    Posted 2 years ago #

    Do some SEO for your website for better results

  22. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    You are welcome. Now that you have removed the block, you can expect your site is indexed by Google very soon.

  23. Mateusz1
    Member
    Posted 2 years ago #

    I do.

    I using seo plugin (all meta in site and blog) and i added my sitemap in google webmaster tools, moreover i had a sitemap plugin too, few good links too. Something else worth doing?

  24. Santosh
    Member
    Posted 2 years ago #

    adding good content which help your visitors that is the bottom line

  25. Mateusz1
    Member
    Posted 2 years ago #

    Sure, content is the king, I know :). I forget that i supportet site with social media (facebook and twitter).

    Ok, thanks for help once again a i must said that english version of this forum is great, very fast ansvers and many users. :)

  26. Mateusz1
    Member
    Posted 2 years ago #

    After your advices site is in google but is another problem. My site is in google but only 8 results (yesterday was 10 lol) and no blog posts in serch results? This is normal?

  27. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Submit a site new map, and keep on adding fresh unique content. Keep track of the results in your Google Webmaster Tools account. Also, remember that Google is under no obligation to index all your pages/posts. Generally, they index posts/ pages that are having no errors or other problems. You can also find out the URLs not indexed and the reasons for not indexing.

    Keep track of these in Google forums, not in WordPress, because this is NOT a WordPress problem.

  28. Santosh
    Member
    Posted 2 years ago #

    use plugin for creating xml sitemap and than submit it to GWT

  29. Mateusz1
    Member
    Posted 2 years ago #

    I had this plugin and i added map to also i had (in gwt opinon) no indexing problems :).

    Ok, thanks for help. Will see results for the week or two.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.