Support » Plugin: NGG Smart Image Search » No searchstring for images entered

  • Resolved richardcostin

    (@richardcostin)


    Hi there! Many thanks for providing this plugin. I am attempting to add the search function to my site but I always get the following error…

    Images will be searched in all galleries of this website.
    The specified searchstring will be searched in the fields Title, Description, Filename and Tags of the respective images. The search is not case sensitive. No searchstring for images entered.

    Thanks, any help much appreciated.
    Richard.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author wpo-HR

    (@wpo-hr)

    Hi Richard,
    your page nature-image-stock-library looks a bit strange.
    At first glance I see two issues.
    1) you use enforced https for your website but the searchform uses http (therefore the security warning). Maybe you did not adjust the website url and home url in the wordpress database to https (first two records in the options table).
    2a) you should either use the searchform widget in your general right sidebar (so it will appear on every page where you use that sidebar) or
    2b) you set up your own search page where you should use the searchform shortcode together with the display shortcode.

    My impression is that you want 2b because you set up the page nature-image-stock-library. In that case just use the searchform shortcode and the display images shortcode on that page (see shortcodes) and no widget searchform.

    Kind regards,
    Harald

    • This reply was modified 2 years, 1 month ago by  wpo-HR.

    Hi Harald, many thanks for getting back to me.

    I am ok with the warning popup, would I expect any additional problems from using HTTPS?

    2b would be a great solution, although I did already try that with the same result…
    https://www.richardcostin.com/search-test/

    It is just a blank page with the following two short codes….

    [hr_SIS_nextgen_searchbox]
    [hr_SIS_display_images]

    Much appreciated,
    Richard.

    Plugin Author wpo-HR

    (@wpo-hr)

    Hi Richard,
    your testpage looks fine and the shortcodes should work as designed.

    But the searchbox shortcode adresses the page http://www.richardcostin.com/search-test/ because it uses your siteurl http://www.richardcostin.com from your wordpress database. Your webserver redirects this request to https://www.richardcostin.com/search-test/ and it seems to me that it looses the search parameters by this redirection.

    You should check your siteurl and homeurl in your wordpress database and adjust it to https if this is not the case already (which I assume).

    Alternatively you could hardcode your https address in the plugin to test the effect, but adjusting the site/homeurl is much more preferable.

    Kind regards
    Harald

    Sensational, many thanks Harald that got it working. Updating the setting (which I thought I had done when I migrated to ssl) fixed it up a treat.

    Many thanks again for your assistance. Do you have a donate page? I would like to thank you for your time and of course the plugin’s development itself.

    Richard.

    Plugin Author wpo-HR

    (@wpo-hr)

    Glad to hear that you solved your problem.
    You are welcome to provide a review/rating for this plugin.

    Harald

    PS: You have really great pictures on your website!

    • This reply was modified 2 years, 1 month ago by  wpo-HR.
    • This reply was modified 2 years, 1 month ago by  wpo-HR.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No searchstring for images entered’ is closed to new replies.