Support » Fixing WordPress » No RSS on localhost installation

  • Thanks to many here I’ve got a blog running on my local system. After lots of futzing with httpd and such, everything seems to work fine – except RSS. I notied this while trying to use an RPC client to send a post to myself.

    The RSS feed ( feed:http://localhost/wordpress/feed/) seems to simply go nowhere, and the browse goes nuts. The RPC client simply reports a failure (but not any Apache-ish one).

    I’m not sure where to start with this one.

    btw: The blog is not in a subdomain, the xmlrpc.php file is in there, and there don’t seem to be any other problems.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Kind readers: Forgot to mention that my feed is turned on in the options, and the encoding is not an issue – it’s unicode 8.


    A) Do you have pretty permalinks turned on? If not, the url will be a bit different… more like http://localhost/wordpress/?feed=rss2

    2) Suppose you drop the “feed:” from the beginning of the URL. (http://localhost/wordpress/feed/)

    c) What sorts of error messages?

    d) There is no d.

    Thx. Yeah, I have the pretty permalinks (in both my local and online installations); the ones in the local blog were a hassle. I tried both of your suggestions, and no luck.

    I did get one useful peice of info finally, from using the ?feed=rss2 variant: It’s some error in a function – the URL can’t be resolved for some unknown reason – and the error code is a -1, which is typical for low-level system stuff.

    (Btw this is the same regardless of which theme I select, so that’s eliminated, and my online version of the theme is ok.)

    I’m using a browser since that’s given me the most feedback. Let’s say I go to my blog <http://localhost/wordpress/&gt; and hit the link for the feed. The link is <feed:http://localhost/wordpress/feed/&gt;. The browser then just spins, trying to load. The same is true of the link <http://localhost/wordpress/feed=rss2&gt;, and variants of that.

    The fact that the browser complaints about the URL and the message that it gives makes me think that there’s something fundamentally ‘off’, as if my machine simply can’t understand a request. I’m thinking Apache, htaccess, etc.


    Well, most browsers will holler about anything starting with “feed:”, so don’t get too hung up on that detail.

    Not sure if this was a typo: <http://localhost/wordpress/feed=rss2> but it is missing a “?” in there.

    But yeah… I got nothin’ to suggest at this point. Anything amusing in the error logs at all?

    Nope, no other info. I did have a typo in the post. I tried an emailing client (like ecto, but not) and it gave me the same info: -1, no feed.

    I’m wondering if there’s some way to drill down into this to diagnose it, like once I hit the feed link, what script gets executed? I’m betting it’s something brutally obvious to an experienced admin, but I probably have to do this the hard way.

    And a complete lack of php knowledge makes it extra fun!!


    And to add insult on top: I traced the function that’s returning the error , and the error code means “unknown error”.

    But for those Mac/Safari users out there, I may have found a solution (as well as a legit bug)! I tried using in the feed url instead of localhost…success!! Maybe the function just has a bug when resolving ‘localhost’.

    <feed://; works!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘No RSS on localhost installation’ is closed to new replies.