Support » Plugin: Postie » No route to host?

  • Resolved loiruca

    (@loiruca)


    Postie is not posting. I already called my hosting – Godaddy – and it’s all clear at their end. I tried searching for it but there is little to none on the subject. Can someone please help me with this issue? I appreciate it!

    Here is the Config message:

    OS: Linux a2plcpnl0072.prod.iad2.secureserver.net 2.6.32-673.26.1.lve1.4.25.el6.x86_64 #1 SMP Wed Apr 5 16:33:01 EDT 2017 x86_64
    PHP Version: 5.6.30
    PHP error_log: error_log
    PHP log_errors: On
    PHP get_temp_dir: /tmp/
    PHP cURL version: 7.36.0
    WordPress Version: 4.7.5
    WordPress Singlesite
    WP_TEMP_DIR: (none)
    WP_HOME: (none)
    home_url(): http://pythiapeay.com
    WP_SITEURL: (none)
    site_url(): http://pythiapeay.com
    WP_DEBUG: Off
    WP_DEBUG_DISPLAY: On
    WP_DEBUG_LOG: Off
    WP_MAX_MEMORY_LIMIT: 256M (default)
    WP_MEMORY_LIMIT: 40M
    DISABLE_WP_CRON: Off
    ALTERNATE_WP_CRON: Off
    WP_CRON_LOCK_TIMEOUT: 60
    iconv: present
    Active plugins
    Postie is in /home/johnlsullivan/public_html/pythiapeay.com/wp-content/plugins/postie/
    Postie Version: 1.8.43
    POSTIE_DEBUG: Off
    Clock

    This shows what time it would be if you posted right now

    WordPress timezone: (0)
    Current time: 2017-05-22 23:35:39
    Current time (gmt): 2017-05-22 23:35:39
    Postie time correction: 0
    Post time: 2017-05-22 23:35:39
    Encoding

    default_charset: UTF-8
    DB_CHARSET: utf8
    DB_COLLATE: database default
    WordPress encoding: UTF-8
    Postie encoding: UTF-8
    Images

    Connect to Mail Host

    Postie connection: sockets
    Postie protocol: imap-ssl
    Postie server: imap.gmail.com
    Postie port: 993
    Unable to connect. The server said: There was an error connecting to the server No route to host

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Wayne Allen

    (@wayneallen-1)

    Some GoDaddy servers don’t allow connections to Gmail. See http://postieplugin.com/postie-godaddy/

    Hi, thanks for your reply. I created a new email in Godaddy like instructed. I checked the config and everything looks good and the first test message I sent posted with no issues. However, when I tried sending other test messages, they don’t post though. The message will only posts if I click on Process Email. Any ideas why this is happening? Prior to creating an email in GoDaddy, when I first tried the plugin, I used a gmail email address and a similar thing happened, the first message posted, but not subsequent ones. Any ideas why? Thanks!

    Plugin Author Wayne Allen

    (@wayneallen-1)

    Thanks for the resource. However, I thought this plugin worked out o box. I don’t know CRON, I added some command at my Cpanel but I’m not sure if this is the right one. /usr/bin/lynx –source http://<pythiapeay.com>/?postie=get-mail >/dev/null 2>&1

    Obviously not because it isn’t posting the messages. I also don’t understand “if you send an email, but nobody accesses the site for 3 days Postie won’t be given the chance to fetch the email and publish the post” …. I’m accessing the site right after I send a message, wouldn’t it be enough for postie to post? How to get a rid of that?

    • This reply was modified 2 years, 6 months ago by loiruca.

    Right after I sent my last message, it looks like the message posted. It took over 30 minutes and I had to refresh 2 pages 3 times. But it posted.

    My images though are showing at the end of the post, like I set too. I added the image inline with the text. Is there a way to show the images inline in the post rather than at the bottom? I also see this in the text where I added the image: [image: Inline image 1]

    Plugin Author Wayne Allen

    (@wayneallen-1)

    >It took over 30 minutes

    Take a look at the “Check for mail every” setting. That controls how often Postie looks for new emails.

    >My images though are showing at the end of the post

    You need to set “Preferred Text Type” to HTML to allow inline images.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘No route to host?’ is closed to new replies.