WordPress.org

Forums

WP-PostRatings
[resolved] No rich snippet will be generated for this data, because it appears to include (13 posts)

  1. mbay0r
    Member
    Posted 8 months ago #

    Hi,

    on some pages im getting "No rich snippet will be generated for this data, because it appears to include multiple aggregate reviews of many items, instead of a single aggregate review of one item" while other pages working fine.

    Any idea?

    thank you

    https://wordpress.org/plugins/wp-postratings/

  2. Lester Chan
    Member
    Plugin Author

    Posted 8 months ago #

    Hmm, the only thing I can think of is plugin conflict, ie there some plugin/theme generate rich text snippet as well.

    Try decactivate other plugins and switch to the default twentyforteen theme

  3. mbay0r
    Member
    Posted 8 months ago #

    i think, i could isolate the problem, it happens only on articles.
    on pages its working fine, any idea?

    EDIT: Same Problem without my child theme, i will check the plugins.
    EDIT2: had deactivated all other plugins, still the same problem.

    any clue?

    thank you very much.

  4. mbay0r
    Member
    Posted 8 months ago #

    maybe its a hint, i use

    <?php if(function_exists('the_ratings')) { the_ratings(); } ?>

    in content.php and content-page.php of my template

  5. Lester Chan
    Member
    Plugin Author

    Posted 8 months ago #

    As mentioned in two threads before, have you tried in the default twentyforteen theme that comes default with WordPress and leave the rest of the plugins deactivated.

  6. mbay0r
    Member
    Posted 8 months ago #

    .

  7. mbay0r
    Member
    Posted 8 months ago #

    sorry, i have to correct myself, after putting
    <?php if(function_exists('the_ratings')) { the_ratings(); } ?>
    into the content.php of the twentyforteen im getting the same error :(

  8. Lester Chan
    Member
    Plugin Author

    Posted 8 months ago #

    Where is the URL I can test it with the Google Rich Snippet?

  9. mbay0r
    Member
    Posted 8 months ago #

  10. Lester Chan
    Member
    Plugin Author

    Posted 8 months ago #

    Did you style the postratings template to include
    <span class="rating">
    <span class="average"><b>5,00</b></span>
    von
    <span class="best">5</span>
    Punkten, basierend auf
    <span class="votes">1</span>
    abgegebenen Stimmen.
    </span>`

    I think that might the reason.

  11. mbay0r
    Member
    Posted 8 months ago #

    well, thats correct, i restored now to your default template.
    Now, it is working on posts, but NOT on pages? :/

    Any Idea?

    https://www.google.com/webmasters/tools/richsnippets?q=http%3A%2F%2Fwww.sportboot-rhein.de%2Fslipstellen%2F

  12. Lester Chan
    Member
    Plugin Author

    Posted 8 months ago #

    I have no idea, since the error doesn't come from the plugin anymore.

  13. mbay0r
    Member
    Posted 8 months ago #

    well, there are no errors now, but google does not recognize it on pages.

    anyway thank you!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.