Support » Plugin: MapPress Maps for WordPress » No Results on search since update/switch to Leaflet

  • Resolved madamadari

    (@madamadari)


    I recently updated the plug-in on a couple of large client sites, and switched to Leaflet to avoid the new Google Maps costs.

    All seemed to be working fine, with all existing maps displaying correctly, however the SEARCH box that appears above the map (after selecting New Map) is no longer returning results on locations that obviously exist.

    https://www.pureportugal.co.uk/pp_new/eg/noresults01.jpg

    https://www.pureportugal.co.uk/pp_new/eg/noresults02.jpg

    If you enter lat, lng it also says ‘no results’ however if you hit enter, it will add a POI marker and zoom into the right area.

    I don’t see search mentioned in the Leaflet Limitations in the documentation, so thought I would check if anyone else is experiencing this, or if it’s a known issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author chrisvrichardson

    (@chrisvrichardson)

    Hi,

    Although the Algolia geocoder used with Leaflet is not perfect, those locations all work for me. Are you still having this problem? If so, my guess is something is causing a javascript error on the page (possibly the theme or another plugin).

    Please email me via my contact page and provide the plugin version you’re using, and a URL for your site.
    http://mappresspro.com/chris-contact

    I have excatly the same problem.

    No results in searchbox. It gives nex javascript error at console:

    Uncaught TypeError: this.ajaxQuery is not a function
    at mapp.Map.search (mappress.min.js?ver=2.50.6:1)
    at mappress.min.js?ver=2.50.6:1
    at navigator.geolocation.getCurrentPosition.timeout (mappress.min.js?ver=2.50.6:1)

    Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No Results on search since update/switch to Leaflet’ is closed to new replies.