Support » Plugin: REST API Log » No REST API Log Entries found

  • I have this plugin installed and enabled. There are two issues.

    1) The message “REST API Log activated! Please visit the Settings page to customize the settings.” appears at the top of every page in the admin. I have gone to the settings page and saved my changes. But there appears to be no way to dismiss this message.

    2) I have several REST API sessions to retrieve WooCommerce orders (using WC 3.0.5) but the REST API log is always empty. I have REST API Log enabled and with no filtering.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Pete Nelson

    (@gungeekatx)

    1) That’s very odd. That should only be displayed once, triggered by the ‘wp-rest-api-log-plugin-activated’ value in the options table, which is supposed to get deleted as soon as it is displayed. Can you give me more info on your hosting environment? I’ll try to recreate the problem. In the meantime, if you can edit the plugin file class-wp-rest-api-log-settings.php and comment out the add_action( ‘admin_notices’ line, that will stop the notice.

    2) I’ll get WC 3.0.5 installed on a fresh WP site and will take a look. If they’re using their own REST API and not the one bundled with WP core, then it will not log those requests, but I’ll have to investigate further.

    According to the WooCommerce documentation, they’re using the WordPress v2 REST API. http://woocommerce.github.io/woocommerce-rest-api-docs/

    Our hosting is on WP Engine.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘No REST API Log Entries found’ is closed to new replies.