Support » Plugin: Yet Another Related Posts Plugin (YARPP) » No related posts.

  • I just have installed newest version of plugin. I added new post with title similar to titles of 21 other posts (it is test XX, where XX is number :)). Posts have the same category and similar titles. But only thing I see is No related posts.

    So which posts are related?

    When I have ‘Automatically display related posts’ checked There is nothing on my site. So I needed to add <?php related_posts();?> in my theme single post view…

    Please help me to fix and/or understand how YARPP works

Viewing 15 replies - 46 through 60 (of 94 total)
  • @the1path great!

    @rahmis but if you build the cache manually, do you get results for that new post?

    mitcho,

    Yes, I do.

    Hi all, if you’re having trouble getting related posts to new posts you write, please try this new beta:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.4.3b1.zip (link will work in a few minutes)

    it looks like i’m having the “no related post” issue as well. i’ve tried clearing the caches of DB Cache Reloaded, W3TC and YARPP, no luck. this only happens on some old posts, not all.

    here’s a few screen shots:

    http://www.jpegtown.com/user_uploads/el8DnpA_Capture.PNG

    http://www.jpegtown.com/user_uploads/CfSUUXi_Capture2.PNG

    here’s the snippet of my yarpp-template-thumbnail.php

    <?php if ($related_query->have_posts()):?>
    	<p style="font-weight: bold;">You might also like:</p>
    	<?php while ($related_query->have_posts()) : $related_query->the_post(); ?>
    		<div class="related_post_thumb">
    	<?php
    		// tambnguyen
    		$width = 90;
    		$height = 90;
    		$classtext = 'related_post_thumb_img';
    		$titletext = get_the_title();
    		$thumbnail = get_thumbnail($width,$height,$classtext,$titletext,$titletext);
    		$thumb = $thumbnail["thumb"];
    		echo '<a href="' . get_permalink() . '" rel="bookmark" title="' . $titletext . '">';
    		echo ($thumb <> '') ? print_thumbnail($thumb, $thumbnail["use_timthumb"], $titletext, $width, $height, $classtext) : $titletext;
    		echo '<span>' . substr($titletext, 0, 40) . '...</span>';
    		echo '</a>';
    	?>
    		</div>
    
    	<?php endwhile; ?>
    	<div class="clearfix"></div>
    <?php endif; ?>

    oh, i’m running WP 3.3 with the official YARPP 3.4.2.

    Hello,

    I have this issue too.

    Running WP 3.2.1 and YARPP 3.4.2. Standard usage, no custom template.

    Every new post has an empty related list. To make the list appear, I have to :

    – Change the relevant score : lower or higher (I tried 5 to 4 then 4 to 5) it does the trick

    or

    – Flush the YARPP cache

    Since the score changing seems to empty the cache, I think this is a cache related issue.

    Best regards,

    @mdatawt, yes, changing the relevance score flushes the cache.

    @mdatawt, @azn137 there was a bug whereby it became very difficult to get related posts on new posts you write. I believe 3.4.3b1 fixes this:

    http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.4.3b1.zip

    Please try installing that version, clearing the cache, then writing a new post and seeing if you get any results. Thanks!

    Nope, 3.4.3b1 still comes up a lot of posts with nothing related, while there were before.

    2 things I’ve noticed:

    1) I keep getting the “Cache computation ended prematurely. Try reloading the page and continuing.” error. It takes about 3-5 tries to get it to complete.

    2) My scores are quite low. I used to see A LOT of related posts with scores higher than 10. This is what it reports: “Score (among those related): avg 9.001, sd 4.842”. I’ve set the threshold down to 3 with the same low results.

    More update: I’ve gone ahead and tried disabling both DB Cache Reloaded (let’s call this DBCR) and W3TC, still same results, so this is definitely not a caching problem, but more like a algorithmic/scoring problem.

    If you want, I can probaly export the YARPP db out to a file for you to inspect.

    Thanks,

    -Tam

    @azn137 What I’m concerned with diagnosing was an issue where *no* new posts were getting related posts… Your score report sounds perfectly healthy, like some posts have related posts and some do not. As for how the results may be different than in the past, I don’t have anything I can really say about that. The scoring of tags and categories in common did become more accurate (though perhaps stricter) in 3.4.x.

    Hiya

    I’m also not getting any related posts but I spotted this error on my page…

    Warning: Invalid argument supplied for foreach() in /...path.../yet-another-related-posts-plugin/class-cache.php on line 231

    Running WP 3.3, Hybrid News – chile of Hybrid 1.0, I have a db prefix, wp super cache. YARPP 3.4.3b2, hotfix.

    I tried the experiments plugin – it won’t build a cache.

    I’m running it on http://www.CADbloke.com but I’ve disabled it for now – not too keen on directory listings in my posts.

    I hope this helps you track down the problem.

    Thanks @cadbloke! I figured out the issue; 3.4.3b3 should fix this issue. http://downloads.wordpress.org/plugin/yet-another-related-posts-plugin.3.4.3b3.zip

    Looks like 3.4.3b3 is working. I added a new post and related posts are there. Thank you so much.

    Fantastic! There’s a little more testing I want to do with 3.4.3b3, but if I don’t find any issues I’ll release it as 3.4.3.

    b3 Works on my site. eg. http://www.cadbloke.com/installing-acne-on-windows-7/

    I haven’t added any new posts (long story :/) but it seems ok. Nice one. Thanks for fixing it so quickly, @mitcho.

    Thanks all for your feedback! 3.4.3 is out. 🙂

Viewing 15 replies - 46 through 60 (of 94 total)
  • The topic ‘No related posts.’ is closed to new replies.