Support » Plugin: Postie » No registered filters

  • Hi!
    I’m a bit annoyed. Although I’ve read the faq’s many times and I’m not a bloody beginner, I don’t get it to run.
    Why do I get those alerts in debug-info?

    No registered filters for wp_handle_upload
    No registered filters for wp_get_attachment_thumb_file
    Registered filters for wp_handle_upload_prefilter
    No registered filters for wp_handle_sideload_prefilter
    No registered filters for pre_move_uploaded_file`

    Do I have to put these filters in my functions.php first?
    My eMails are posted only with tmptitle und tmptxt. Category, subject, text and images are completely irgnored.
    Is there a detailed documentation about useable tags and shortcuts and where to place them in the email-text?

    I’m using the following plugins:
    acf-field-for-contact-form-7/acf-field-for-contact-form-7.php => 1.6
    advanced-custom-fields/acf.php => 5.9.6
    cf7-grid-layout/cf7-grid-layout.php => 4.10.0
    smtp-mailer/main.php => 1.1.2
    with twenty-twentyone-template

    My purpose is to use postie with a cf4-form and post the retrieved data for a closed usergroup.

    Thanks

    • This topic was modified 1 month, 1 week ago by zeichenstrom.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Wayne Allen

    (@wayneallen-1)

    Most of the stuff is there for support/debug purposes. Specifically the section you’re asking about is reporting if any filters are registered which I use to determine if some other plugin could be affecting how Postie works. Essentially you can just ignore it.

    >My eMails are posted only with tmptitle und tmptxt

    This sounds like the “from” email address in the email is not a valid user with posting permissions in your WordPress. The “tmptitle” post is a bug that I need to fix.

    You can test this by turning on “Allow Anyone To Post Via Email”

    Thread Starter zeichenstrom

    (@zeichenstrom)

    Thanks for your reply.
    You are right, tmptitle/txt appears since I’ve unchecked “Allow Anyone To Post Via Email”. Before this, the posts were just empty with “News from the field”-Headline.
    Once, I deactivated every plugin, but that did not change the result.

    Plugin Author Wayne Allen

    (@wayneallen-1)

    Are you using cUrl connections or Sockets? Sockets are preferred and cUrl sometimes gives results like you’re seeing.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.