Support » Plugin: LifterLMS » No Redirect Page after Course completed

  • Resolved Monbro

    (@monbro)


    I get the email and the popup notification when a course is finished. But where do I set the completition page with further instructions or a thank you page? The user just sees the last lesson again of the course. I think this is not really helpful for him??

    Any way to change it / add a redirect?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Natalie

    (@nrherron)

    Hi

    We don’t have a dynamic way of doing that kind of redirect natively in LifterLMS at this time.

    However, you can add some custom code that will do that. You can either add it to your functions.php file or we have a customisations plugin you can use: https://lifterlms.com/docs/how-do-i-add-custom-code-to-lifterlms-or-lifterlms-launchpad/ (to edit this plugin you’ll want to use the Plugin Editor on the site.)

    function my_llms_mark_complete( $student_id, $object_id, $object_type, $trigger ) {
    
    if ( course id number === $object_id) {
    
    $url = ‘link of page you want to redirect to’;
    wp_safe_redirect( $url );
    
    }
    }
    add_action( 'llms_mark_complete', 'my_llms_mark_complete', 999, 4 );

    With this code you will want to replace the course id number with the id number of the course you want the redirect to happen on. You can find the course id number on the editing page of the course, it will be the number in the url of that page.

    If you would like all course completed redirects to go to the same page then you can replace: ‘if ( 123 === $object_id)’ with ‘if ( ‘course’ === $object_type )’ to affect every course the same way.

    I hope this helps!

    Please let us know if you have any further questions about installing this code!

    Thanks and take care,

    Yeah, thank you very much for your quick reply! Love your software!
    BTW: The “got questions?” popup everywhere on your page https://lifterlms.com I found super annoying!! All the time it comes, on every new visit, multiple tabs…

    Unfortunately It says, header already sent :-/ Any idea how to overcome this?
    EDIT: Ah no my fault.

    I only had to add a ‘exit();’ after wp_redirect();

    • This reply was modified 2 months, 2 weeks ago by  Monbro.
    Plugin Support Natalie

    (@nrherron)

    Hi @monbro,

    I’m glad you got that figured out!

    Also, in regard the help pop up I will pass that along! Thank you for the feedback!

    Let us know if you have any further issues or questions!

    Thanks and take care,

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    Since I haven’t heard back from you in a while I’m going to mark this topic resolved. If you need some more help here please just reply and I’ll reopen it and get back to work.

    Best,

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.