Support » Plugin: Advanced noCaptcha & invisible Captcha (v2 & v3) » No reCAPTHCA on Contact Form 7 w/ shortcode [anr_nocaptcha g-recaptcha-response]

  • Resolved ymf

    (@ymf)


    Hi. I installed this plugin by recommendation from “3-SPAM Fixes / Contact Form 7 (v5.1)” support thread. Specifically,

    1. Removed any v3 Google keys from CF7 Integration and removed the CF7 shortcode [recaptcha] from the form settings , then saved.

    2. Deactivatged my previous reCAPTCHA plugin “Google Captcha (reCAPTCHA) by BestWebSoft”

    3. Install/Activated your plugin “Advanced noCaptcha & invisible Captcha”

    4. Went to settings of your plugin, inserted Google v2 reCaptcha keys, selected other settings.

    5. Inserted the plugin’s shortcode [anr_nocaptcha g-recaptcha-response] into CF7 Form settings where the shortcode [reCaptcha] used to be.

    6. Saved.

    Now testing: reCAPTCHA shows on the login/registration/forget password pages. But it does not show on the CF7 form. What can I do?

Viewing 8 replies - 1 through 8 (of 8 total)
  • UPDATE: as I said, reCAPTCHA does not show on the Contact Form 7 in the intended place (where I placed the shortcode [anr_nocaptcha g-recaptcha-response]).

    However, when trying to send a test email via the CF7, after clocking the send button I see the following error message (in red font) right above the send button where the reCAPTCHA was supposed to be:

    Please solve Captcha correctly.

    Plugin Author Shamim Hasan

    (@shamim51)

    Do you use any caching plugin? tried clear cache?
    Do you see any error in your browser console?
    Can you give me url of your contact form so that i can try?

    @shamim51,

    I’ve clear the cache and even temporarily deactivated the “W3 Total Cache”, same symptoms.

    Yes I see error in browser console!

    recaptcha__en.js:508 Uncaught Error: reCAPTCHA placeholder element must be an element or id
        at Object.gY [as render] (recaptcha__en.js:508)
        at anr_onloadCallback ((index):536)
        at GY (recaptcha__en.js:514)
        at V4 (recaptcha__en.js:501)
        at recaptcha__en.js:516
        at recaptcha__en.js:536
    gY @ recaptcha__en.js:508
    anr_onloadCallback @ (index):536
    GY @ recaptcha__en.js:514
    V4 @ recaptcha__en.js:501
    (anonymous) @ recaptcha__en.js:516
    (anonymous) @ recaptcha__en.js:536

    I’ve sent you the url of my contact form privately via your blog (I don’t want unnecessary publicity).

    Meanwhile, just in case, this is my CF7 form’s code:

    <p>Your Name (required)<br />
        [text* your-name akismet:author] </p>
    
    <p>Your Email (required)<br />
        [email* your-email akismet:author_email] </p>
    
    <p>Subject<br />
        [text your-subject] </p>
    
    <p>Your Message<br />
        [textarea your-message] </p>
    
    <p>[anr_nocaptcha g-recaptcha-response]</p>
    
    <p>[submit "Send"]</p>

    Thank you!

    • This reply was modified 1 year, 2 months ago by ymf. Reason: Added CF7 form's code
    Plugin Author Shamim Hasan

    (@shamim51)

    Do you have any other form in that page?
    Did you change any code in this plugin?
    Did you add this plugin shortcode/code in any other place in that page?

    @shamim51 , the answer is “No” to all 3 questions. (BTW, I just updated CF7 to the most recent 5.1.1; no change in the above described symptoms.)

    I did more investigation and found a conflict w/ “Yoast SEO” plugin (most recent version 9.3):

    * When “Yoast SEO” plugin is deactivated (out of ~20 other plugins on my site), the reCAPTHA starts showing up on the CF7’s contact page;

    * On the other hand, when ALL plugins are deactivated but the following three:
    “Yoast SEO”
    “Contact Form 7”
    “Advanced noCaptcha & invisible Captcha”
    then no reCAPTHA shows up on the CF7’s contact page.

    However, further investigation pointed to my (rather antiquated) theme 🙁 . When temporarily switching to “Twenty Nineteen”, the reCAPTHA shows on the CF7’s contact page with all my current plugins active.

    So, thank you for your help. Issue solved.

    How did you resolve this?? I have the exact same issue, also with Yoast.

    @budget101 , the issue was not with “Yoast SEO” but with “Contact Form 7”. I’ve solved my issue by switching to a different forms plugin “Contact Form by WPForms – Drag & Drop Form Builder for WordPress”.

    @ymf That’s strange because the issue I was experiencing with Contact Form 7 went away when I disabled Yoast, until I added the <p></p> tags, which work with both Contact form 7 And Yoast enabled.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘No reCAPTHCA on Contact Form 7 w/ shortcode [anr_nocaptcha g-recaptcha-response]’ is closed to new replies.