WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] No "Publish" but "Submit For Review" button displayed to site admin

[Resolved] No "Publish" but "Submit For Review" button displayed to site admin

  • There have been a strange issue going on with one of our blog. The problem started about 2 months ago, and it is not plugin conflict since same issue is reproducible without any plugin as well.

    There is only one user on blog, which is site admin.

    When we want to write a new post, we get only two buttons “save draft” and “Submit for Review” and there is not any publish button shown which prevents us to post new blog entries.

    Any help is greatly appreciated

Viewing 15 replies - 1 through 15 (of 20 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    We’ve got the same problem. It happened right after an update to 3.0.1. The site admin can only “save draft” and “submit for review”, and saved drafts do not appear in the list of drafts at all (possbly they have not been saved at all).

    Drafts and posts written prior to the update can still be saved and published as before.

    We’ve tried changing the theme and turning off plugins.

    Hi.

    Here’s what I did today and it worked:

    Define a new admin user

    Log in with that admin user

    Lower your previous admin to contributor

    Increase it back to administrator

    Log in with your original admin

    It will now work.

    Delete the new admin

    Now it’s back to normal.

    I tried that and found out more: apparently not any new user, comment, page or entry is added to the database. I can modify any existing data. It’s as if the SQL “insert into” doesn’t work and I can only “update” the database tables.

    I’m experiencing the same problem.

    Just overnight the “Publish” changed to “Submit for Review”.

    I’m using 3.0.1.

    I cannot Ad new posts, Save Drafts, nor New User. I changed the theme, nothing. Deleted plugins I’m not using. Deactivated plugins, nothing.

    When I try to Submit for Review, the post doesn’t get sent nor does it get saved in the drafts…it just switches to the Posts page listing.

    any suggestions? I’m stuck. My website is a brick.

    I also tried esmi suggestion but to no avail. I still get the Submit For Review.

    Waiting for a reply…Thank you

    @esmi
    – Reverted back to default theme after deactivating all plugins, no avail, the issue is still reproducible

    @comprarmag it seems like you are not logged in with admin user because Submit for review button comes when you don’t have capability to submit post.Please check your user role.

    My embarrassingly simple solution: I had run out of space with my provider, who prohibited any additions to the database. Hence no saving of any new material, which made wordpress offer no save button (and not actually do any submitting either).

    @kapil Chugh I wish it was that simple…I am logged in as administrator. I have actually three administrators and all three do not allow me to post.

    USER ROLE checked!

    actually…i believe i found the solution..after reading HerrRau’s discovery…I looked at my DB and it’s passed the amount.

    I will find out tomorrow…and see if that’s the problem-o.

    Will report back after i find out.

    i tryed suggeston from johnd28 with no luck
    and my database is on my own server at home so if there is a way to get the amount in each database higher, im open for suggieston.

    Hi just thought I’d tell you about my experience with this same problem of seeing “submit for review” instead of “publish”.
    Tried all the fixes above but no luck. The problem in my case was that the server went down while I was working on the site and this led to the database not being closed correctly and hence becoming corrupt. What I had to do to fix it was to go into the correct mysql database and click on “repair database” then all leapt instantly back into life!

    Thanks acorn it worked a treat I had visions of having to rebuild 2 sites

    This happened to me and I contacted my host and they were able to fix it.Your theme may need to be upgraded to latest version also.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] No "Publish" but "Submit For Review" button displayed to site admin’ is closed to new replies.