Support » Plugin: MultiSafepay plugin for WooCommerce » No PSR-18 clients found

  • Resolved Junni

    (@junni)


    Today I updated the plugin to version 4.1, but payment transactions aren’t working anymore. Users get the following message: “No PSR-18 clients found. Make sure to install a package providing “psr/http-client-implementation”. Example: “php-http/guzzle6-adapter””.

    Fixed it temporarily by downloading & installing the previous version (v3.8).

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter Junni

    (@junni)

    Extra information:

    – WordPress version: 5.6.1
    – Woocommerce version: 5.0.0

    Yep, got the same issue here.
    Seems like it only applies to the iDeal Payment Methode.

    We have deactivated iDeal, when we try to enable it again we get indeed the above mentioned error:


    No PSR-18 clients found. Make sure to install a package providing “psr/http-client-implementation”. Example: “php-http/guzzle6-adapter”.

    Plugin Author multisafepayplugin

    (@multisafepayplugin)

    @junni @davelo
    Could you provide us with a list of installed plugins, so we can reproduce this error?
    In the mean time, you can keep using 3.8.0
    https://downloads.wordpress.org/plugin/multisafepay.3.8.0.zip

    havemaskwilltravel

    (@havemaskwilltravel)

    I did not get the error “No PSR-18 clients found”, but I was not able to conduct a payment using iDEAL either (creditcard payment did work though). Under WooCommerce > Settings > Payment methods I switched iDEAL off, saved settings and switched it back on, causing iDEAL to work in the frontend again.

    I did downgrade MultiSafepay to 3.8.0 and WooCommerce to 4.9.2, which caused payment icons to look properly again (they appeared very large after updating to the most recent versions of both plugins).

    Edit:
    Upgrading to 4.1.3 does solve the icon problem, but won’t allow me to use iDEAL payment method. So I’m using 3.8.0 for the time being which allows iDEAL payment.

    Thread Starter Junni

    (@junni)

    @multisafepayplugin : a list of all active plugins:

    • 404page
    • Advanced Woo Search
    • AffiliateWP
    • AffiliateWP – Store Credit
    • BackWPup
    • Booster for Woocommerce
    • Booster Plus for Woocommerce
    • bpost shipping
    • Conditional Discounts for WooCommerce by ORION
    • Custom Product Tabs for WooCommerce
    • Divi Commerce
    • Embed Plus for YouTube – Gallery, Channel, Playlist, Live Stream
    • Facebook Pixel
    • Google Analytics for WordPress by MonsterInsights
    • Homepage Control
    • Jetpack door WordPress.com
    • Loco Translate
    • ManageWP – Worker
    • MultiSafepay
    • Regenerate Thumbnails
    • Scratch & win giveaways
    • Shortcode in Menus
    • Smush
    • WooCommerce
    • WooCommerce Admin
    • WooCommerce PDF Invoices & Packing Slips
    • WP Rocket
    • YITH Custom Thank You Page for Woocommerce
    • Yoast SEO
    • This reply was modified 7 months ago by Junni.
    Plugin Author multisafepayplugin

    (@multisafepayplugin)

    @junni
    We just released 4.1.4 which might fix your issue.
    Please let us know if this will solve your reported issue.

    Thread Starter Junni

    (@junni)

    @multisafepayplugin : plugin updated and everything seems to work as intended. Thanks a lot!

    Plugin Author multisafepayplugin

    (@multisafepayplugin)

    @junni
    That’s great to hear.
    I will keep this support ticket open for a bit for @davelo to see if this also resolved his issue.

    @multisafepayplugin i updated it to 4.1.5; and it’s working again. Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘No PSR-18 clients found’ is closed to new replies.