Support » Plugin: Advanced AJAX Product Filters » No products found bug, needs fix

  • I noticed that if you reload the page when no products found, the message loses its style. Also, if you click back, if you try to clear all filters, unselect or select any filter the page reloads like if ajax stopped working.

    The reason i noticed this bug is because when a user finds himself with no products found i use product upsells. If the user clicks on an upsell and then decides to go back he will see the unstyled no products found message and if he then tries to clear/change filters his page is going to reload no ajax.

    You can try reloading when no products found in your demo: https://woocommerce-products-filter.berocket.com/shop/ then after reloading also try using the filters.

    • This topic was modified 9 months, 1 week ago by theotheo.
    • This topic was modified 9 months, 1 week ago by theotheo. Reason: Grammar, link add
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author RazyRx

    (@razyrx)

    Hello,

    It happenes because when page do not have products it has another template, that do not have needed elements, plugin cannot create it in correct place and reload page to display it correct.
    With AJAX loading plugin place “No products” template inside products element.

    Regards,
    Oleg

    Thread Starter theotheo

    (@theotheo)

    If i understood correct i need to place the no products template inside product loop template and the issue will be gone right?

    Do you know how i can do this?

    • This reply was modified 9 months, 1 week ago by theotheo.
    Plugin Author RazyRx

    (@razyrx)

    Hello,

    Not sure is it possible, because those changes can cause some other issues.

    Regards,
    Oleg

    Thread Starter theotheo

    (@theotheo)

    From what i’ve tried it seemed a bit hard to get the template inside the loop but i don’t think it’s impossible. As you said erros could be caused.

    Basically the answer to this is that it can’t be resolved right?

    Is it related to how this certain plugin works or does any filtering plugin face this?

    Thank you for taking time to respond to my queries.

    • This reply was modified 9 months ago by theotheo.
    • This reply was modified 9 months ago by theotheo.
    Plugin Author Dmytro Holovnia

    (@dholovnia)

    Hello,

    The No Products message is provided by the WooCommerce. We are adding the same message when there is no products after the filtering.
    On page reload we are not changing page content. So if filtered age is not overwritten by your theme it will be shown same mage as we show. If page was changed/replaced by the theme it is up to the theme if/how show the message.

    You can create child theme and overwrite the page with added/changed message.

    Regards,
    Dima

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No products found bug, needs fix’ is closed to new replies.