Support » Plugin: Justified Gallery » No preview in the WordPress editor

  • wayap

    (@wayap)


    Hi !
    I can’t have a preview of my gallery when i’m writing a post.
    The bloc doesn’t even show and if I want to select it I have to go to the “show the list” mode.
    In front end everything works well.
    I tried to update everything, and to uninstal/reinstall the plugin, but no luck.

    Can you help ?

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mateusz Czardybon

    (@matczar)

    Hi,

    Do you have the latest plugin version? What version of WordPress do you have?

    Click F12 to open dev tools and open tab “Console”. Refresh the edit page and check if there are any errors.

    Thread Starter wayap

    (@wayap)

    My version of WordPress is 6.0.2
    My version of the plugin is 1.6.0

    There is an API error wich I think has nothing to do with this problem.

    Please see the link which is a screenshot of the inspector when I target the place where the preview should be :

    https://reportage.marianneliegeois.com/wp-content/uploads/jgnopreview

    It seems that the preview is disabled somehow ?

    Plugin Author Mateusz Czardybon

    (@matczar)

    The gallery preview is displayed in an iframe, and you can try to open the iframe’s URL in a new tab.

    • Open dev tools (I’m using Chrome)
    • Switch to the “Network” tab
    • Refresh edit page with gallery
    • Look for the resource ?dgwt-jg-gutenberg-preview=active&dgwt-jg-wpnonce...
    • Copy its URL and open it in a new browser tab – you should see the gallery
    • If you don’t see the gallery, open dev tools here and check Console for any errors
    Thread Starter wayap

    (@wayap)

    Ok, doing what you say I can see the gallery in a new tab. It works. So what’s wrong with the editor ? I don’t understand.

    Plugin Author Mateusz Czardybon

    (@matczar)

    I just checked on a clean install of WordPress 6.0.2 with plugin version 1.16 and the preview while editing the page works fine.

    Unfortunately, it is difficult to say what could be the reason.

    You can turn off plugins one by one to check if there is any conflict or switch temporarily to another theme.

    Thread Starter wayap

    (@wayap)

    Ok.
    I can’t find the problem.

    But thank you for your help anyway, it’s very nice !

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.