Support » Installing WordPress » “no posts matched your criteria”

Viewing 5 replies - 1 through 5 (of 5 total)
  • Sorry, I thought I was entering that phrase in the search box, and I entered it as a subject line and posted it by mistake. 🙁

    The search results weren’t relevant to my problem anyway, so here it is. I just installed a blog and I tried out several templates. With each template (including the default one), the “Comments” link at the bottom of the post (one post so far) gives me the error message “no posts matched your criteria.” One template gives a 404. There’s no way for people to post in response to a post, and the problem isn’t with a particular template. What’s missing?

    Thanks for your help,
    Lois

    Moderator James Huff

    (@macmanx)

    Have you cleared your browser cache and cookies?

    I used a different browser and cleared the cookies, and the problem is still there. The blog is at http://summers.wordsweave.com/ . What happens for you if you click on the Comments link at the bottom of the page?

    Thanks for your help,
    Lois

    Hi there.

    Looks like you’ve got a problem in the permalink structure somewhere. Going via the ‘post id’ link http://summers.wordsweave.com/index.php?p=3 (which I guessed) you can access the correct page which lets you post comments.

    Try recreating your permalink structure from the control panel (go to options>permalink>update permalink structure). See if that gives you any errors. The rest of the permalink structure seems to work though, which is a little strange. Maybe it just needs a little kick or something!

    Give it a go and see what happens anyway.

    Rob

    That was it. Thanks very much.

    To get it to work, I had to add “index.php” to the permalink and take out%category%. It didn’t like %year% either, but it works with /index.php/%post_id%. At least it works.

    Thanks again,
    Lois

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘“no posts matched your criteria”’ is closed to new replies.