Support » Installation » “no posts found” on new install

“no posts found” on new install

  • I just installed a brand new version of WP 2.9 for the first time. When I log-in to the dashboard, the edit posts page says “no posts founds”, even though it also says “all(2) | published(2)”. Viewing on the front-end gives me a “Not found! Sorry, this page does not exist.” message.

    I tried creating a new post and it posts just fine. I looked in phpMyAdmin to confirm it is there.

    I have the same problem on the edit pages section of the dashboard.

    I am currently using PHP Version 5.2.5.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Another quick note: I have no widgets installed, I tried several templates and I repaired the table in phpMyAdmin. Still have the problem.

    I just tried downgrading to 2.8.6 to see if there was an error in 2.9, but the problem persists.

    Anyone out there have any clues?



    Forum Moderator

    Try re-uploading all WP files (except for your wp-config.php file) from a fresh download of WordPress.

    I deleted the database and all this files on the server. I then downloaded 2.9 again and gave it a fresh install. The problem is still there.

    Does anyone have any error testing suggestions?

    I do have root access to the server, so can make changes at that level if needed. I am also quite fluent in PHP, so can tweak the actual code as well.

    Definitely not a common error!

    Have you had a look at the apache error logs? Might be some sort of hint in there.

    Hi guys,

    I have the same problem. I’ve been using WP since 2.1 or something like that. I see the problem in any version after 2.7, but NOT in 2.7. I don’t want to run the older version due to security concerns.

    I see the following when I click “edit posts” when I’m logged in as admin:

    Edit Posts Add New
    * All (56) |
    * Published (56)
    No posts found

    There’s another problem as well: when I click “add new post”, the page comes up but without any submit/preview buttons!

    I’ve done a lot of searching on this issue and others have said it might have to do with AJAX. Yes, of course I’ve uninstalled and done a complete reinstall (including themes). Yes, I’ve disabled all plugins. I’ve checked everything I can think of.

    Any ideas? I’m really at the end of my rope on this one.


    Make sure your plugins are activated.

    Hi Bill,

    If only it was something so silly. I’ve disabled, enabled, deleted, re-installed all plugins. I’ve tried doing WP re-installs with plugins enabled and disabled.

    I’ve repaired and optimized all databases on the server. No dice.

    Other ideas?


    Tried a different browser? Would be an obvious option, even if just to rule it out.

    yep -tried a variety of browsers. As with Will, no plug-ins, tables all repaired. etc. Nothing.

    I re-uploaded the ‘wp-admin’ folder from a fresh download like Esmi suggested and my posts are now visible on edit.php where they weren’t before. Worth a try.

    per the request of Chris_K, i looked at the Apache error log and all seems fine.

    any other ideas? Anyone?

    I have been unable to import my word press blog into my new web site, which uses Word Press as well. Says can’t complete the task. I went to expoert on the original blog and import with the web page. The export is in ‘.xml’ format. Any suggestions?

    I’m having the same problem. I have a blog with 100+ posts but they all of a sudden they don’t show up in my control panel or on my site. I upgraded to the latest version (2.9), and even installed a fresh blog on my server. No dice. I’m using 1and1 hosting and have php5 enabled.
    All of my other sites are working fine so I’ve ruled out anything with 1and1’s databases. I’ve tried deleting all my htaccess files so I don’t think it’s that either. Then I tried adding a new user to the blog, disabling plug-ins, changing my passwords and AUTH_KEYs. So, why did my WP all of a sudden die?

    Oh, and everything is redirecting to my single.php page. But my permalink structure is set to “/blog/%post_id%” and my htaccess looks like this

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘“no posts found” on new install’ is closed to new replies.