WordPress.org

Support

Support » Plugins and Hacks » Polylang » "No posts found", "No pages found" with polylang 0.9

"No posts found", "No pages found" with polylang 0.9

  • Hey,

    I updated from polylang 0.8.10 to polylang 0.9. Now i don’t see any pages or posts in the admin panel but there is because “Published (31)”. If I replace 0.9 with 0.8.10 i see the posts again. I don’t see even if i add a new page. I have my filters so that every posts should be seen.

    What could be the problem?

    WordPress version: 3.4.2

    http://wordpress.org/extend/plugins/polylang/

Viewing 15 replies - 1 through 15 (of 49 total)
  • Plugin Author Chouby

    @chouby

    Does the filter break only posts and pages or also categories, post tags, comments ?

    I’m not sure what you mean with that but my filters are like this: Show all dates, View all categories.

    I can see items at Posts/Categories and Posts/Tags (edit-tags.php). Only posts and pages are invisible (edit.php).

    Plugin Author Chouby

    @chouby

    I propose two tests:
    1. I made a small correction in the development version. Could you try it? http://downloads.wordpress.org/plugin/polylang.zip
    2. If the above does not work, could you try deactivating other plugins to detect a conflict?

    Didn’t work :(. Also tried disabling all other plugins.

    Plugin Author Chouby

    @chouby

    If you edit polylang/include/admin-filters.php at line 42 and replace

    add_filter('parse_query',array(&$this,'parse_query'));

    by

    //	add_filter('parse_query',array(&$this,'parse_query'));

    it should disable the language filter for posts and pages (should allow you to use v0.9 features without this issue), but for now I do not understand what’s wrong with your site.

    I have the same problem and don t see posts and pages , categories are shown up only under categories not through the language filter, under dates nothing is visible.
    Would be glad if somebody knows the solution.
    in the frontend everything is fine.
    The only thing was that after the update also hidden installed languages were shown in the language widget
    Thanks Susanne

    After editing admin-filter.php I see posts and pages again.

    Plugin Author Chouby

    @chouby

    @susanne
    What do you call “hidden installed languages” ?

    Hi Chouby ! A language that i installed but have no posts and pages and didn t add it to the widget before.It seems something with the filter is not ok! Luckily in the frontpage everything is like usual and all other updates went smooth this is the first time thats not going like it should be. Thanks Susanne

    Same problem here. No posts or pages visible in backend.
    Seems like a nasty problem and will probably get fixed soon?

    Thanks in advance.

    Hi,
    I installed two hours ago the Version 0.9 of Polylang, and post, pages, categories disappeared just when pluggin was activated.

    After reading this support conversation and adding this to polylang/include/admin-filters.php:

    // add_filter(‘parse_query’,array(&$this,’parse_query’));

    Posts and pages are now visible in dashboard.

    But, the categories list remains empty, they not appear…

    I continue trying and look forward to the updates that are mentioned here …

    thanks!!!!

    // add_filter(‘parse_query’,array(&$this,’parse_query’));
    This didnt work on my site!!!
    Thanks a lot
    Susanne

    Hi again,

    apologizes, I’m a beginner in wordpress. I detect that in my case, the problem is that I haven’t see the “filter content by language” option on top menu of the dashboard 🙁

    I returned polylang/include/admin-filters.php to initial code and, so far, polylang works for me.

    Plugin Author Chouby

    @chouby

    Could you try again with the development version taht I just updated? Should be 0.9.0.2.

    @susanne
    You are right about the widget. I did not pay attention to this before. I will look for a patch

    Plugin Author Chouby

    @chouby

    The bug of the language switcher should now be corrected in the development version (should be 0.9.0.3). http://downloads.wordpress.org/plugin/polylang.zip

Viewing 15 replies - 1 through 15 (of 49 total)
  • The topic ‘"No posts found", "No pages found" with polylang 0.9’ is closed to new replies.
Skip to toolbar