Support » Installing WordPress » No posts found after upgrade

  • I just upgraded to WP1.0.1rc. I hoped everything would go fine (I had some problems with the 1.0 release).
    Now I’m getting this message on the main page:
    >Sorry, no posts matched your criteria.
    I checked (with phpAdmin) and I have 47 posts in the database. I think I’ve set up everything ok, because WP is able to find my links and my preferences. And I’m able to login… (so the user/passwd exists).
    In the admin area > user : This says that I’ve made 47 posts, but when I click the 47, the posts don’t get displayed.
    Then I tried this: but I didn’t have to make those changes (everythings was already in place). Still, no posts…
    The strange thing is that, if you look at the calendar, you can see that there are posts (If you hover over them, you can see the title), but they don’t get displayed…
    Has someone an idea of whats going wrong here (or what I did wrong) ??

Viewing 5 replies - 1 through 5 (of 5 total)
  • Sorry, I forgot to give the link to my site.
    Here it is:

    Umm… did you change anything? I went to the site and I could see all your posts just fine.

    You are right, they do show up… if you’re not using Firebird. It seems like a browser problem. I’m using Firebird 0.7 here.
    I tried with IE6, Mozilla 1.4 and Opera 7.11. They both work. But Mozilla Firebird fails… I already cleared my cache a couple of times, removed cookies etc. Nothing seems to work… The strange thing is that the site does work with Mozilla.
    Is someone else experiencing this strange problem?
    Firebird 0.8 will be released in a couple of days/hours. Maybe it’s a Firebird-bug, and it might be fixed in the 0.8 release…

    Ahhh… other people were having bizarre MySQL errors with Firebird if I recall… I wonder why that is?

    Not because of the browser…
    I solved the problem. I made a mess in my Firebird profile. I made a new one and copied the bookmarks. I probably installed too many XUL-games…
    I don’t want to start a browser war, but Firebird is a good browser. The reason that it doesn’t display some sites correctly is just because those sites don’t comply with the W3C standards. Most sites work with IE, because IE ignores what it doesn’t know and displays the site anyway (that’s why there are so many bad sites around…).
    Back on topic… This wasn’t a browser problem nor a WP problem. My computer was just acting weird (again). If somebody else is having the same problem: just make a new profile and copy the necessary files (from your current profile) into it… (bookmarks.html, user.js, …)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No posts found after upgrade’ is closed to new replies.