Support » Fixing WordPress » No posts are listed to choose as static page

  • I have experienced this problem sporadically on multiple WordPress installs over different version (though all on my own server).

    Under Settings-Reading-Front Page Displays…

    You can choose ‘A static page’ but when you go to choose a post page, the only pages that show up are actual Pages, and none of the posts. I mean, only Pages show up in list of available posts, too. This is maddening, as I really want to have a post page as my static home page and don’t want to use an actual WP ‘Page’ for my home page.

    This does not seem to be a theme problem because it happens even on brand new installs using the default themes.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Only Pages can be used as a ‘static page’, hence the name.

    I was under the impression that you could choose from your published posts, and have one of those set as your home page. If that isn’t the way it works now, did it used to?

    By going into the database, I set the value for “page_on_front” to the id of a post and accomplished what I was wanting to do. If that isn’t what the “display on front page” “static page” “post page” option in the control panel isn’t meant to do I don’t know what the point of it is… seems to be the same option value in the database.

    @snthorv Just curious, does using a post instead of a page make any differences in the way your home page displays? Why do you need to do that?

    I wanted to use a post for SEO/Permalink purposes.

    It probably wasn’t the end of the world to use a page and even then could have fiddled until I got what I wanted, hacking the htaccess file or tweaking the permalink format for pages. It just seemed to me that I used to be able to use a post if I wanted to and it looked to me (and looks still) like that this option should have done it for me, too.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No posts are listed to choose as static page’ is closed to new replies.